The default bug view has changed. See this FAQ.

Australis: "Sidebars" widget toolbarbutton has not image when it is placed on toolbar on WindowsXP Luna

VERIFIED FIXED in Firefox 30

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: mixedpuppy)

Tracking

(Blocks: 1 bug)

30 Branch
Firefox 30
x86_64
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 unaffected, firefox30- verified)

Details

(Whiteboard: [Australis:P3-][aurora29-unaffected])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8384173 [details]
screenshot

Steps To Reproduce:
1. Enter Customize Mode
2. Move "Sidebar" to toolbar
3. Exit Customize Mode

Actual Results:
"Sidebar" widget toolbarbutton is empty

(About unnecessary scrollbar, I will file a separate bug)
(Reporter)

Updated

3 years ago
Summary: Australis: "Sidebar" widget toolbarbutton has not image when it is placed on toolbar → Australis: "Sidebar" widget toolbarbutton has not image when it is placed on toolbar on WindowsXP Luna
(Reporter)

Updated

3 years ago
Summary: Australis: "Sidebar" widget toolbarbutton has not image when it is placed on toolbar on WindowsXP Luna → Australis: "Sidebars" widget toolbarbutton has not image when it is placed on toolbar on WindowsXP Luna

Updated

3 years ago
Whiteboard: [Australis:P3-][aurora-unaffected]

Comment 1

3 years ago
Duping because the other bug has slightly more info and it's essentially the same issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 978475
(Reporter)

Updated

3 years ago
tracking-firefox30: ? → ---
(Reporter)

Comment 2

3 years ago
This problem re-appears on
https://hg.mozilla.org/mozilla-central/rev/44ae8462d6ab
Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140312030201
Status: RESOLVED → REOPENED
tracking-firefox30: --- → ?
Resolution: DUPLICATE → ---
Whiteboard: [Australis:P3-][aurora-unaffected] → [Australis:P3-][aurora29-unaffected]
status-firefox29: --- → unaffected

Comment 3

3 years ago
(In reply to Alice0775 White from comment #2)
> This problem re-appears on
> https://hg.mozilla.org/mozilla-central/rev/44ae8462d6ab
> Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0
> ID:20140312030201

The scrollbars as well, or just the icon?
Flags: needinfo?(alice0775)
(Reporter)

Comment 4

3 years ago
just the icon.
Flags: needinfo?(alice0775)

Comment 5

3 years ago
This file :
http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/Toolbar-XP.png

is missing the sidebar icon.

Comment 6

3 years ago
Note that the backed out patch in bug 960198 had the Toolbar-XP.png icons packaged as Toolbar.png .

Comment 7

3 years ago
(In reply to Tim Nguyen [:ntim] from comment #6)
> Note that the backed out patch in bug 960198 had the Toolbar-XP.png icons
> packaged as Toolbar.png .

Here's the file for reference : http://hg.mozilla.org/mozilla-central/raw-file/29c4b76e7364/browser/themes/windows/Toolbar.png
(Assignee)

Comment 8

3 years ago
Created attachment 8390110 [details] [diff] [review]
Toolbar-XP.png patch

actual image will also be attached
Assignee: nobody → mixedpuppy
Attachment #8390110 - Flags: review?(gijskruitbosch+bugs)
(Assignee)

Comment 9

3 years ago
Created attachment 8390111 [details]
Toolbar-XP.png
Attachment #8390111 - Flags: ui-review?(gijskruitbosch+bugs)

Comment 10

3 years ago
Comment on attachment 8390110 [details] [diff] [review]
Toolbar-XP.png patch

Review of attachment 8390110 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming this was chucked through an image optimizer appropriately, r=me
Attachment #8390110 - Flags: review?(gijskruitbosch+bugs) → review+

Updated

3 years ago
Attachment #8390111 - Flags: ui-review?(gijskruitbosch+bugs) → ui-review+
(Assignee)

Comment 11

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/dbf07d71ffc1
https://hg.mozilla.org/mozilla-central/rev/dbf07d71ffc1
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
tracking-firefox30: ? → -

Updated

3 years ago
Keywords: verifyme
I was able to confirm the fix for this bug on Windows XP 64-bit [1], using Firefox 30 Beta 2 (Build ID: 20140505140302).

[1] Mozilla/5.0 (Windows NT 5.2; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
status-firefox30: affected → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.