Closed Bug 978778 Opened 6 years ago Closed 6 years ago

MOZ_PURPLE check needed in the about menu

Categories

(Instantbird :: Other, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 954801

People

(Reporter: clokep, Unassigned)

References

Details

10:46:53 - flo-retina: would be interesting to check if libpurple is loaded correctly
10:47:05 - Mic: Ah!
10:47:25 - Mic: We show libpurple information on the About dialog, maybe that's why it crashes when trying to open it.
10:47:30 - aleth: iamjayakumars: Which protocols are you using? gtalk and fb only?
10:47:38 - flo-retina: Mic: do we?
10:47:45 - Mic: Yes, the libpurple version.
10:47:51 - flo-retina: oh yes
10:47:59 - flo-retina: doesn't that need #ifdef MOZ_PURPLE added?
The proxy UI will need similar ifdefs.
There's already checks for this:
 - http://mxr.mozilla.org/comm-central/source/im/content/aboutDialog.xul#53

Mic added this in bug 954801: http://hg.mozilla.org/comm-central/rev/d0b952d42fc4
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 954801
Hmm, I didn't remember we made these changes, but I was thinking that now that we have a build time define that's easy to use, we may want to use it instead of a runtime check. Especially I thought we may want to avoid packaging the proxy UI files that are irrelevant without libpurple. But I guess they aren't really heavy, so it probably doesn't really matter.
I kind of dislike making them build time dependent, it would mean you can't get an IB without libpurple (somehow) and then add libpurple (once it's built as an extension). Maybe just a pipe dream, but it's where my mind went.

I think the "right" solution would be to actually make these overlays that are part of the extension. Thoughts?
(In reply to Patrick Cloke [:clokep] from comment #4)

> I think the "right" solution would be to actually make these overlays that
> are part of the extension. Thoughts?

That would be better.

The real right solution would be to finally fix the proxy handling, so that libpurple prpls use the proxies defined by Mozilla preferences.
You need to log in before you can comment on or make changes to this bug.