Closed Bug 978836 Opened 6 years ago Closed 6 years ago

switch to production APK Factory servers

Categories

(Firefox for Android :: Web Apps, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: myk, Assigned: myk)

Details

Attachments

(1 file)

Now that the production APK Factory servers are up and running, we should switch Fennec Nightly/Aurora to them.  This'll prevent existing users from updating their apps, so we'll want to communicate that issue (and how to reinstall apps) in conjunction with the switch.

To switch to the production servers, we'll set browser.webapps.apkFactoryUrl to:

  https://controller.apk.firefox.com/application.apk
Assignee: nobody → myk
Status: NEW → ASSIGNED
Priority: -- → P1
ozten: I'm requesting feedback from you so you can confirm that these are the correct URLs!
Attachment #8389696 - Flags: review?(mark.finkle)
Attachment #8389696 - Flags: feedback?(ozten.bugs)
Attachment #8389696 - Flags: review?(mark.finkle) → review+
Comment on attachment 8389696 [details] [diff] [review]
patch v1: update URLs to production servers

Review of attachment 8389696 [details] [diff] [review]:
-----------------------------------------------------------------

Production URL looks perfect.
Attachment #8389696 - Flags: feedback?(ozten.bugs) → feedback+
(In reply to Austin King [:ozten] from comment #2)
> Production URL looks perfect.

Both of them?  There are two being changed, and you only mention one.  Sorry to bug you again, I just want to make absolutely sure both URLs are correct!
Flags: needinfo?(ozten.bugs)
Comment on attachment 8389696 [details] [diff] [review]
patch v1: update URLs to production servers

Review of attachment 8389696 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, they both look correct.

Sorry for the imprecise language.
(In reply to Austin King [:ozten] from comment #4)
> Yes, they both look correct.
> 
> Sorry for the imprecise language.

No worries, and thanks for the quick response!
Flags: needinfo?(ozten.bugs)
Severity: normal → blocker
Comment on attachment 8389696 [details] [diff] [review]
patch v1: update URLs to production servers

[Approval Request Comment]

Bug caused by (feature/regressing bug #): 
  This is not a bug but rather a switch from a development to a production
  instance of a web service on which Fennec's new implementation of the Web
  Runtime depends.  We previously planned to make this change during Fx29's
  Aurora cycle, and it's now time to make it.

User impact if declined:
  Users will experience instability when using the parts of the feature that
  depend on the web service.

Testing completed (on m-c, etc.): 
  This hasn't merged to Central yet, but Fennec and Marketplace QA has been
  testing against the production instance for a while now by manually setting
  the affected preferences to the same values.

Risk to taking this patch (and alternatives if risky): 
  The patch is low-risk.  The alternative is to disable the Web Runtime
  feature entirely, which is medium-risk (given the amount of code that would
  be disabled/reenabled by that change).

String or IDL/UUID changes made by this patch:
  None.
Attachment #8389696 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2244835a4ade
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8389696 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.