Closed Bug 978933 Opened 7 years ago Closed 7 years ago

gaia-marionette should not care about the order of its environment variables

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S4 (28mar)

People

(Reporter: gaye, Assigned: evanxd)

References

Details

(Whiteboard: [p=5])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
gduan
: review+
gaye
: feedback+
Details | Review
Evan can you fix this? The order of the environment variables (including RUN_CALDAV_SERVER) should not matter.

https://github.com/mozilla-b2g/gaia/blob/master/bin/gaia-marionette#L7
Assignee: nobody → evanxd
Hi Gareth,

Sorry, I didn't notice this bug.
Sure, let me fix that.
Thanks.
Hi Gareth,

How about this patch https://github.com/mozilla-b2g/gaia/pull/16435?
Could we do install radicale server if INSTALL_CALDAV_SERVER flag equal 1 in the gaia-marionette file?
Or we just would like to do some documentation to notice users to install the radicale before they run the calednar related tests?

How do you think how do we handle the radicale installation?

Thanks.
Flags: needinfo?(gaye)
And the Bug 973876 is fixing the sudo things.
discussed with Evan, things we can do here:

1. remove installing radicale part from bin/marionette
2. add a makefile rule for installing radicale
3. disable caldav-related integration tests if radicale isn't available (but give a warning message for installing radicale by make.)
Hi Gareth,

How do you think about Comment 4?

I would like do this to fix the sudo issue.
The issue stays too long.

Thanks.

Evan
That sounds good to me!
Flags: needinfo?(gaye)
Evan, please leave an update here since you listed this bug on the weekly report.
Flags: needinfo?(evanxd)
Attached file Pull request
Hi Gareth,

Could you give me the feedback about the WIP patch?
We skip the CalDAV related tests with the https://github.com/mozilla-b2g/gaia/pull/17515/files#diff-93c8db4b2f7d60eb0c3cc4893191e727R29 way.
Thanks.
Attachment #8395593 - Flags: feedback?(gaye)
Hi Tim,

I had a WIP patch at https://github.com/mozilla-b2g/gaia/pull/17515.

Thanks.
Flags: needinfo?(evanxd)
Target Milestone: --- → 1.4 S4 (28mar)
Hi all,

After discussed with gaye and yuren, we would like to have SKIP_TESTS variable. And  if we detect the radicale CalDav server is NOT installed, then we could do SKIP_TESTS="<caldav tests>" params with doing gaia-marionetted.

And we add make task for installing the Radicale CalDAV server. The CalDAV server helper in https://github.com/mozilla-b2g/gaia/blob/master/apps/calendar/test/marionette/lib/radicale.js#L65-L83 will active it at run time.
(In reply to Yuren [:yurenju][:小朱] from comment #4)
> discussed with Evan, things we can do here:
> 
> 1. remove installing radicale part from bin/marionette
> 2. add a makefile rule for installing radicale
> 3. disable caldav-related integration tests if radicale isn't available (but
> give a warning message for installing radicale by make.)

The https://github.com/evanxd/gaia/commit/5c36049631db009653e47418964b7acc827647f0 commit is WIP patch for the above things.
Attachment #8395593 - Flags: feedback?(gaye)
Comment on attachment 8395593 [details] [review]
Pull request

Hi Gareth,

I updated the patch for the "SKIP_FILES" solution.
Please help me to take a look and give me feedback for it.
https://github.com/mozilla-b2g/gaia/pull/17515/files#diff-55743de39889bf62680340b58fffbd1eR7

Thanks.
Attachment #8395593 - Flags: feedback?(gaye)
Comment on attachment 8395593 [details] [review]
Pull request

Hi Yuren,

Please help me to review the patch.
Thanks.
Attachment #8395593 - Flags: review?(yurenju.mozilla)
Comment on attachment 8395593 [details] [review]
Pull request

Thanks Evan. This is much better. Deferring review to yuren since I am not great at bash...
Attachment #8395593 - Flags: feedback?(gaye) → feedback+
Hi Gareth,

Thanks for the feedback.
Attachment #8395593 - Flags: review?(yurenju.mozilla)
Comment on attachment 8395593 [details] [review]
Pull request

Yuren have no time to review the patch now.
Thanks for George's help.

Hi George,

Please help me to review the patch.
Thanks. :)
Attachment #8395593 - Flags: review?(gduan)
Comment on attachment 8395593 [details] [review]
Pull request

r=gduan
This patch is fine. Please remember to open two follow-up bugs as below.
1. We need the same change for gaia-marionette-parallel. 
2. follow-up of https://github.com/mozilla-b2g/gaia/pull/17515#discussion_r11009589
Attachment #8395593 - Flags: review?(gduan) → review+
Hi George,

Thanks for the review.
master: https://github.com/mozilla-b2g/gaia/commit/12bc17ae4988c9532749e95f39968a894dd757a9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 973876
Blocks: 987351
Whiteboard: [p=5]
You need to log in before you can comment on or make changes to this bug.