Firefox cannot render webpages correctly if font-family attribute contains Sun-ExtB

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: fn84b, Unassigned)

Tracking

27 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

2.38 KB, application/x-zip-compressed
Details
821.79 KB, application/x-zip-compressed
Details
Reporter

Description

5 years ago
Posted file testcases.zip
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; InfoPath.3; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; rv:11.0) like Gecko

Steps to reproduce:

1. Unzip the attachment (testcases.zip), and you will get two files "testcase ok.html" and "testcase not ok.html"
2. Use Firefox to open "testcase not ok.html" and "testcase ok.html", respectively.


Actual results:

Firefox can display "testcase ok.html" correctly, but when displaying "testcase not ok.html", some text is missing and sometimes a big black block is shown on the page, which covers the table, as shown in the screenshot.


Expected results:

Both html files should be displayed completely and correctly.
Reporter

Comment 1

5 years ago
Posted file screenshots.zip
Reporter

Comment 2

5 years ago
Also this bug exists on Firefox 27.0.1, 28 beta and Nightly 30.0a1.

Also I want to point out that I can also reproduce this bug on IE 11, but it is not reproducible on Chrome 33. I was first wondering if this issue was due to a bug of Windows 8.1, but later I found that Chrome worked fine with the testcase, so I guess it's still an issue with Firefox.

Lastly, I have Sun-ExtB version 6.0 installed on my system.
Reporter

Updated

5 years ago
Component: Untriaged → General
Is it reproducible with HWA disabled?
Reporter

Comment 4

5 years ago
(In reply to Masatoshi Kimura [:emk] from comment #3)
> Is it reproducible with HWA disabled?

No. After disabling hardware acceleration, I can no longer reproduce this issue. Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.