TEXTAREA with scrollbars does not behave properly to Page up and Page down (PgUp PgDn)

VERIFIED DUPLICATE of bug 4302

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 4302
17 years ago
15 years ago

People

(Reporter: Ren Hoek, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3) Gecko/20010801
BuildID:    20010801

I was editing a TEXTAREA, that had scrollbars. At the bottom I pushed page up a
few times to edit something at the top, after I was at the top, I wanted to edit
but could not find the carot, so I pushed the up key. Turns out that page up and
down only affected the vertical scrollbar and did not move the cursor up as
would be desirable.

Reproducible: Always
Steps to Reproduce:
1.Enter a few lines into a TEXTAREA so you get a vertical scrollbar
2.Position cursor at the bottom
3.Push page up a few times
4.Push a cursor key

Actual Results:  You are back at the original position of the carot.

Expected Results:  It should move the carot a page up or down, and that in
effect should move the vertical scroll bar up or down. Page up and down should
not interact with the vertical scroll bar directly.

Comment 1

17 years ago
Confirming 2001083106 linux.
I think there are some dups flying around - but I can't find one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All

Comment 2

17 years ago
It's a dupe of the good old bug 4302.

Comment 3

17 years ago
thx

*** This bug has been marked as a duplicate of 4302 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
vrfy dupe. I just love mid airs ;-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.