Closed Bug 979143 Opened 6 years ago Closed 2 years ago

laverdad.com sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

All
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: hsteen, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-ve][serversniff][needscontact])

The laverdad.com site intends to redirect mobile browsers to the laverdad.com/movil/ address, however the site is not configured to detect Firefox OS devices as smartphones. 

HTTP traffic analysis:

Firefox Android is redirected to /movil/, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 16339
content-type: text/html; charset=UTF-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 16339
location: /movil/
content-type: text/html; charset=UTF-8

Earlier bug: bug 828441
See Also: → 828441
The company which created the Web site
http://www.iconoscs.com/html/portafolio.php

1st attempt with an editor at Diario La Verdad
http://twitter.com/MozWebCompat/status/484194229581651969
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-ve][serversniff][contactready] → [country-ve][serversniff][sitewait]
The issue is still here.
Firefox for Android has no issue with the site. 
Just a matter of UA sniffing.

We had no reply from the first contact. We need to find a better contact.
I'm trying the email address. web@laverdad.com
no answer. no modifications. switching to needscontact.
Whiteboard: [country-ve][serversniff][sitewait] → [country-ve][serversniff][needscontact]
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.