The default bug view has changed. See this FAQ.

Bookmarking animation goes the wrong way in RTL mode

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Blocks: 1 bug, {rtl})

unspecified
Firefox 30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
What it says in the summary. It looks a bit silly, having the star move from the menu dropmarker to the star...
(Assignee)

Updated

3 years ago
Whiteboard: [Australis:P3]

Updated

3 years ago
Blocks: 931343
(Assignee)

Comment 1

3 years ago
Created attachment 8385306 [details] [diff] [review]
adjust Australis' bookmarks animation for rtl,
Attachment #8385306 - Flags: review?(dao)
(Assignee)

Updated

3 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8385306 [details] [diff] [review]
adjust Australis' bookmarks animation for rtl,

>+      let isRTL = getComputedStyle(this.button).direction == "rtl";
>       let buttonRect = this.button.getBoundingClientRect();
>       let notifierRect = this.notifier.getBoundingClientRect();
>       let topDiff = buttonRect.top - notifierRect.top;
>       let leftDiff = buttonRect.left - notifierRect.left;
>       let heightDiff = buttonRect.height - notifierRect.height;
>       let widthDiff = buttonRect.width - notifierRect.width;
>       let translateX = (leftDiff + .5 * widthDiff) + "px";
>       let translateY = (topDiff + .5 * heightDiff) + "px";
>-      this.notifier.style.transform = "translate(" +  translateX + ", " + translateY + ")";
>+      let desiredTransform = "translate(" +  translateX + ", " + translateY + ")";
>+      if (isRTL) {
>+        desiredTransform += " scaleX(-1)";
>+      }
>+      this.notifier.style.transform = desiredTransform;

s/desiredTransform/transform/
Attachment #8385306 - Flags: review?(dao) → review+
(Assignee)

Comment 3

3 years ago
w/ nit,

remote:   https://hg.mozilla.org/integration/fx-team/rev/b45d126adc15
(Assignee)

Updated

3 years ago
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b45d126adc15
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
(Assignee)

Comment 5

3 years ago
Comment on attachment 8385306 [details] [diff] [review]
adjust Australis' bookmarks animation for rtl,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: RTL users have the bookmark animation going the wrong way (from dropmarker to star instead of vice versa)
Testing completed (on m-c, etc.): on m-c, locally
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8385306 - Flags: approval-mozilla-aurora?
status-firefox29: --- → affected
status-firefox30: --- → fixed
Attachment #8385306 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

3 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/bdaacace9232
status-firefox29: affected → fixed

Updated

3 years ago
QA Contact: cornel.ionce
Verified as fixed on latest Nightly (build ID: 20140313030202) and latest Aurora (build ID: 20140313004000).
Tested on Windows 7 64 bit, Ubuntu 12.04 and Mac OS X 10.9.
- verified using the "He", "Ar" and "Fa" locales
- verified by creating the string preference "intl.uidirection.en" and set it the value "rtl".
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.