Last Comment Bug 979300 - Main menubutton separator is on the wrong side in rtl mode
: Main menubutton separator is on the wrong side in rtl mode
Status: RESOLVED FIXED
[Australis:P3][good first verify]
: rtl
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: All All
-- normal (vote)
: Firefox 30
Assigned To: :Gijs (away until Feb 27)
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 909349
Blocks: australis-cust 870605
  Show dependency treegraph
 
Reported: 2014-03-04 07:01 PST by :Gijs (away until Feb 27)
Modified: 2014-03-06 06:05 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
fix separator background position for Australis' menu panel button, (1.64 KB, patch)
2014-03-04 07:24 PST, :Gijs (away until Feb 27)
mdeboer: review+
sledru: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image :Gijs (away until Feb 27) 2014-03-04 07:01:00 PST

    
Comment 1 User image :Gijs (away until Feb 27) 2014-03-04 07:24:38 PST
Created attachment 8385349 [details] [diff] [review]
fix separator background position for Australis' menu panel button,
Comment 2 User image Mike de Boer [:mikedeboer] 2014-03-04 07:33:02 PST
Comment on attachment 8385349 [details] [diff] [review]
fix separator background position for Australis' menu panel button,

Review of attachment 8385349 [details] [diff] [review]:
-----------------------------------------------------------------

Nice & clean!
Comment 3 User image :Gijs (away until Feb 27) 2014-03-04 08:13:43 PST
remote:   https://hg.mozilla.org/integration/fx-team/rev/1cd60fd54c7a
Comment 4 User image Ryan VanderMeulen [:RyanVM] 2014-03-04 13:27:46 PST
https://hg.mozilla.org/mozilla-central/rev/1cd60fd54c7a
Comment 5 User image :Gijs (away until Feb 27) 2014-03-04 14:34:52 PST
Comment on attachment 8385349 [details] [diff] [review]
fix separator background position for Australis' menu panel button,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: RTL users have their main menu button "border" in the wrong place
Testing completed (on m-c, etc.): on m-c, locally
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Comment 6 User image :Gijs (away until Feb 27) 2014-03-05 07:06:26 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/c48879d0c178

Note You need to log in before you can comment on or make changes to this bug.