Closed Bug 979336 Opened 6 years ago Closed 4 years ago

tuteve.tv sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: cesar, Assigned: cesar, Mentored)

References

()

Details

(Whiteboard: [country-pe][serversniff][sitewait])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140218135856

Steps to reproduce:

enter tuteve.tv


Actual results:

stay in tuteve.tv


Expected results:

should redirect to m.tuteve.tv
Check returned: 
Significant difference in source code:
Response sent to Firefox OS has Content-Length: 23573
Response sent to Firefox Android has Content-Length: 262

Firefox Android redirected to http://m.tuteve.tv, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 23573
content-type: text/html

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 262
location: http://m.tuteve.tv
content-type: text/html; charset=iso-8859-1
Whiteboard: [country-pe]
I confirm that there is backend browser sniffing intended to redirect mobile browsers to tuteve.tv's mobile site. This detection fails to recognise Firefox OS devices as smartphones. The result is that Firefox Android is redirected to http://m.tuteve.tv, Firefox OS is not redirected - these HTTP headers from the request analysis shows that it gets the desktop webpage:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 23573
content-type: text/html
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-pe] → [country-pe][serversniff][contactready][mentor=hsteen]
This bug is now fully analysed and anyone in the Mozilla community is welcome to reach out (politely! ;)) to tuteve.tv. 

You can use this letter template or tweet:
https://wiki.mozilla.org/Compatibility/StdLetters#Spanish

and also include this URL:
http://webcompat.com/simplebug/#mozilla/979336
to give the site's webmaster a quick overview of the bug.

If you contact the site, please assign the bug to yourself and change "[contactready]" to "[sitewait]" in the box named "Whiteboard" (ask me if you can't change it).

Thank you!
Mentor: hsteen
Whiteboard: [country-pe][serversniff][contactready][mentor=hsteen] → [country-pe][serversniff][contactready]
Assignee: nobody → cesar
Whiteboard: [country-pe][serversniff][contactready] → [country-pe][serversniff][sitewait]
fixed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.