Closed Bug 979341 Opened 7 years ago Closed 6 years ago

Error page displayed in Cost Control FTU, after setting Data usage limit

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S3 (14mar)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: viorela, Assigned: mai)

References

Details

(Keywords: qablocker, regression, Whiteboard: [xfail])

Attachments

(2 files)

Attached image screenshot.png
# STR
1. Launch Cost Control app
2. Tap Next
3. From Data Report page select Reset report Monthly, then tap Next
4. Switch on data use alert, then set Data usage limit to 0.1 MB 
5. Tap Done 

# Expected results:
Data usage page is displayed

# Actual results:
An error page is displayed, as seen in screenshot attached

The error is reproducible manually.

Device: Hamachi
Gaia      6df4533f14ec2645bb13d8a803a5151583ca13a8
Gecko     https://hg.mozilla.org/mozilla-central/rev/529b86b92b1d
BuildID   20140304040200
Version   30.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Keywords: regression
blocking-b2g: --- → 1.4?
Keywords: qablocker
Whiteboard: [xfail]
QA Contact: bzumwalt
Regression Window

Last Working Build:
Environmental Variables:
Device: Buri v1.4 Master Mozilla RIL
BuildID: 20140303135252
Gaia: dfae3744607257206e37483dc3f431108baf70fb
Gecko: 9584fced1895
Version: 30.0a1
Firmware Version: v1.2-device.cfg

First  Broken Build:
Environmental Variables:
Device: Buri v1.4 Master Mozilla RIL
BuildID: 20140303142352
Gaia: fd883f4f086f95f2a9d2f94c7299fa7780aee19d
Gecko: aa4d76646fd8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia/First Broken Gecko: Issue DOES reproduce
Gaia: dfae3744607257206e37483dc3f431108baf70fb
Gecko: aa4d76646fd8

First Broken Gaia/Last Working Gecko: Issue does NOT reproduce
Gaia: fd883f4f086f95f2a9d2f94c7299fa7780aee19d
Gecko: 9584fced1895


Push log: hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9584fced1895&tochange=aa4d76646fd8
Please refer to this regression window as the correct regression window:

Last Working Build:
Environmental Variables:
Device: Buri v1.4 Master Mozilla RIL
BuildID: 20140303135252
Gaia: dfae3744607257206e37483dc3f431108baf70fb
Gecko: 9584fced1895
Version: 30.0a1
Firmware Version: v1.2-device.cfg


First  Broken Build:
Environmental Variables:
Device: Buri v1.4 Master Mozilla RIL
BuildID: 20140303142352
Gaia: fd883f4f086f95f2a9d2f94c7299fa7780aee19d
Gecko: aa4d76646fd8
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia/First Broken Gecko: Issue does NOT reproduce
Gaia: dfae3744607257206e37483dc3f431108baf70fb
Gecko: aa4d76646fd8

First Broken Gaia/Last Working Gecko: Issue DOES reproduce
Gaia: fd883f4f086f95f2a9d2f94c7299fa7780aee19d
Gecko: 9584fced1895

Push Log: https://github.com/mozilla-b2g/gaia/compare/dfae3744607257206e37483dc3f431108baf70fb...fd883f4f086f95f2a9d2f94c7299fa7780aee19d
This is a regression from bug 858017.
Blocks: 858017
Hi Josh, this error screen landed with the DSDS patches and it's related with the ability of Cost Control of determine the data SIM card. I'm not rejecting you supposition but, before back-out, please let us confirm the STR and look for causes. Thank you.
Assignee: nobody → mri
You're right, the problem is related with the splitting we made in the bug 858017. Backing out and resolving this as WFM.
The backout is not clean as we have landed more functionality since then so it is preferable to provide a dedicated fix here. WIP.
Attached file patch1.0
Load network interfaces on the fte, necessary for add a new alarm.

Salva, could you review the patch?

Regards
Attachment #8386601 - Flags: review?(salva)
Comment on attachment 8386601 [details] [review]
patch1.0

It's fine. Thank you.
Attachment #8386601 - Flags: review?(salva) → review+
Blocking as a regression
blocking-b2g: 1.4? → 1.4+
Joe, please take into account that this patch should be also uplifted to v1.3T branch once Bug 858017 is uplifted to that branch. Thanks!
Flags: needinfo?(jcheng)
Target Milestone: --- → 1.4 S3 (14mar)
Master: cb2ec525478919738b2e476777312043fd57539f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Already merged in master so changing nom to v1.3T?
blocking-b2g: 1.4+ → 1.3T?
Hi Noemi, if it impacts 1.3T, does it impact 1.3? Thanks
Flags: needinfo?(jcheng)
(In reply to Joe Cheng [:jcheng] from comment #14)
> Hi Noemi, if it impacts 1.3T, does it impact 1.3? Thanks

No, it doesn't since the new code for alarmas has not been uplifted to v1.3 branch. It will only be needed on those branches having Bug 858017 landed.
blocking-b2g: 1.3T? → 1.3T+
Duplicate of this bug: 980865
Hi Ying Xu, heard that you will be doing uplifts to 1.3T branch. After you completed the uplift, can you please set status-b2g-v1.3T to fixed? please let us know if you have problems with it. thanks
Flags: needinfo?(ying.xu)
Tested and working
1.3
Platform version: 28.0
Build ID: 20140319100231
Git commit: f2f2be55

1.4
Platform version: 30.0a2
Build ID: 20140319105930
Git commit: c036afe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.