Closed Bug 979467 Opened 8 years ago Closed 8 years ago

Stop running tests in top-level documents

Categories

(Testing :: Mochitest, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 508664

People

(Reporter: ehsan.akhgari, Unassigned)

Details

We keep running into this problem where people don't realize that running path/to/test.html runs tests in a totally different environment than running path/to.  The latter uses the test runner page which means the test page won't be top-level, it will have a different viewport size, etc., all of which are detectible from tests.  Can we just run all tests in the test runner always?
We should, there's a patch, I don't know what the status of it is.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508664
You need to log in before you can comment on or make changes to this bug.