Closed Bug 979499 Opened 6 years ago Closed 6 years ago

Panel Subview anchor arrow is invisible on RTL (and if we made it visible, it'd point the wrong way)

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Gijs, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

(Keywords: rtl, Whiteboard: [Australis:P3-])

Attachments

(3 files)

No description provided.
Assignee: nobody → mdeboer
Comment on attachment 8386840 [details] [diff] [review]
Patch v1: update panel sub-view anchor arrow and gradient in RTL mode

Review of attachment 8386840 [details] [diff] [review]:
-----------------------------------------------------------------

r=me assuming you've tested this on OS X and Windows (bonus points for Linux, but I imagine if Windows and OS X are fine then so is Linux)
Attachment #8386840 - Flags: review?(gijskruitbosch+bugs) → review+
I did (test it)!

Pushed as: https://hg.mozilla.org/integration/fx-team/rev/f36bc67c32f7
Status: NEW → ASSIGNED
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f36bc67c32f7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
Comment on attachment 8386840 [details] [diff] [review]
Patch v1: update panel sub-view anchor arrow and gradient in RTL mode

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: subview anchor arrow pointing in the wrong direction in RTL mode
Testing completed (on m-c, etc.): merged to m-c
Risk to taking this patch (and alternatives if risky): minor
String or IDL/UUID changes made by this patch: n/a
Attachment #8386840 - Flags: approval-mozilla-aurora?
Attachment #8386840 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Attached image rtlView.jpg
Gijs, the localized builds prior to the date this bug was fixed, are no longer on ftp so I cannot reproduce this issue.

Please check the attachment (AR latest Aurora on Win 7, same on RC 29 release candidate) and let me know if this is the expected behavior so I can continue verifying on the remaining platforms.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Petruta Rasa [QA] [:petruta] from comment #7)
> Created attachment 8412565 [details]
> rtlView.jpg
> 
> Gijs, the localized builds prior to the date this bug was fixed, are no
> longer on ftp so I cannot reproduce this issue.
> 
> Please check the attachment (AR latest Aurora on Win 7, same on RC 29
> release candidate) and let me know if this is the expected behavior so I can
> continue verifying on the remaining platforms.

Yes, the screenshot looks correct to me.
Flags: needinfo?(gijskruitbosch+bugs)
Attached image AboutFxArrow.jpg
Thank you, Gijs! Please see below my results and let me know your thoughts and if a follow-up bug is needed.

I have verified the arrow appearance on Firefox 29 RC (20140421221237) and latest Aurora 30.0a2 2014-04-24 under Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.7.5.

On Windows and Mac the behavior is similar - the ">" arrow is displayed for History, Developer, Sidebar (30.0a2), Character Encoding and Bookmarks.
On Ubuntu there are no arrows - I believe this is expected since it is the same on en-US version.

For all platforms, the "<" arrow is displayed for the "Open Help Menu (?)" option, please see the attachment.
(In reply to Petruta Rasa [QA] [:petruta] from comment #9)
> On Ubuntu there are no arrows - I believe this is expected since it is the
> same on en-US version.

This is a bug, though. Arrows should be visible on all platforms. However, this bug is not introduced by the fix in this one, so it can become VERIFIED.

Could you file a bug about the missing arrows on Ubuntu? It'd be great if you could attach your set of screenshots in there too!
Flags: needinfo?(mdeboer) → needinfo?(petruta.rasa)
Thank you, Mike! I've created bug 1003053 for the missing arrow under Linux.

It would also be good to know what to do about the "Open Help Menu" issue described in comment 9 in order to mark this bug as verified, although I think is rather related to bug 967110.
Flags: needinfo?(petruta.rasa)
(In reply to Petruta Rasa [QA] [:petruta] from comment #11)
> It would also be good to know what to do about the "Open Help Menu" issue
> described in comment 9 in order to mark this bug as verified, although I
> think is rather related to bug 967110.

It's good to see an inverted arrow there! So as far as I'm concerned, a-ok.
(In reply to Mike de Boer [:mikedeboer] from comment #12)
> It's good to see an inverted arrow there! So as far as I'm concerned, a-ok.
Thanks! Moved this discussion in bug 967110.

Marking as verified as per above comments.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.