Closed Bug 979537 Opened 6 years ago Closed 6 years ago

mobile/android/base/geckoview_resources.zip deps are wrong

Categories

(Core Graveyard :: Embedding: Packaging, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla30

People

(Reporter: nalexander, Assigned: nalexander)

Details

The issue is that geckoview_resources.zip does not depend on ANDROID_GENERATED_RESFILES, so that it doesn't spur strings.xml to be built (and subsequently packaged).

This manifests itself as res/values/strings.xml missing from geckoview_resources.zip, which causes https://github.com/mfinkle/geckobrowser/issues/8.

We can band-aid or take this opportunity to move more of this Android resource logic in moz.build, since I hate hand maintaining Makefile deps.
https://hg.mozilla.org/integration/fx-team/rev/cc782d6580cb
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/cc782d6580cb
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
This is looking good, I see that

http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-android/1394711746/geckoview_library.zip

contains 

  -rw-rw-r--     70084  13-Mar-2014  08:48:54  geckoview_library/res/values/strings.xml
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.