Closed Bug 97971 Opened 22 years ago Closed 22 years ago

Sanity check should check statuses, resolutions, everconfirmed & number of votes.

Categories

(Bugzilla :: Administration, task, P2)

2.15

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: CodeMachine, Assigned: CodeMachine)

Details

Attachments

(1 file, 1 obsolete file)

Sanity check should find bugs with open status and resolution or closed status
and no resolution.

It should use globals.pl to find out what is an open status so this knowledge
can be changed centrally.
Taking ...

I'm also going to deal with everconfirmed matching status UNCONFIRMED on this
bug.
Assignee: justdave → matty
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16
I will be uploading a patch to this after bug #30731 is checked in because that
has code I'll be using.
QA Contact: matty → jake
Status: NEW → ASSIGNED
And also checking everconfirmed against the number of votes.
Summary: Sanity check should find bugs with open status and resolution or closed status and no resolution. → Sanity check should check statuses, resolutions, everconfirmed & number of votes.
Attached patch 5 new checks. (obsolete) — Splinter Review
Attachment #49452 - Attachment is obsolete: true
I haven't tried to apply/run this patch yet, but my initial scan of the code 
looks good.  I'll try to get some basic testing done soon so I can stamp it 
w/a "-review" on it.
Comment on attachment 49479 [details] [diff] [review]
Without the warning this time.

OK, looks good to me.
r=jake
No second review required.
Attachment #49479 - Flags: review+
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
QA Contact: jake → default-qa
You need to log in before you can comment on or make changes to this bug.