Closed Bug 979909 Opened 6 years ago Closed 6 years ago

Update pdf.js to version 0.8.1114

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30

People

(Reporter: yury, Assigned: yury)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

Changes since last update:
#4340 Share ColorSpace.getRgb() between all sub-classes.
#4224 Focus container when arrow/navigation keys are pressed
#4229 Get progress bar for PDF streams in Chromium by passing the expected content length to the page
#4341 Fix spacebar scrolling in Firefox (4224 follow-up)
#4292 Fix wrong page being displayed when entering/exiting Presentation mode with zoom set to 'page-fit'
#4331 Minor clean-ups
#4335 Correct formatting of locale id before submitting to l10n
#4342 Implement Retina assets
#4350 Ctrl/cmd + S = save PDF instead of viewer.html
#4345 Skip the Math.sqrt for clamped values in convertToRgb
#4346 Fill the initial JBIG2 buffer with 0xFF only if defaultPixelValue is set
#4333 Made viewer's webViewerLoad callable from outside viewer.js
#4344 Remove embeddedFontsUsed from API.
#4361 Remove unused calculation from bad merge.
#4324 Faster JBIG2 decoding
#4348 Refactor XRef in obj.js
#4357 Allow a url to omit the protocol
#4266 Updated to current latest stable version of jshint
#4365 Fix parsing of JP2 images
#4355 Put mask data to the canvas in small slices.
#4354 Use a cache to minimize the number of Name objects.
#4336 Special-case 24-bit RGB image-handling
#4353 Use Array.join() to build up strings in more places.
#4367 Remove unneeded |oldtypes| variable from bidi.js.
#4362 Add 'registered' and 'trademark' to mapPrivateUseChars (bug 925985)
#4343 Use only one resource url for moz central build.
#4381 Transfer GRAYSCALE_1BPP and RGB_24BPP arrays when possible.
#4375 Reset annotation stream; reset page annotation promise
#4388 Start counting from actual beginning of PDF file
#4391 Remove FakeStream.
#4382 Avoid extra allocations in ensureBuffer() caused by an off-by-one error.
#4356 Optimizations for 1 bpc images
#4366 Rejects invalid fpgm table when too many functions
#4383 Use RGB_24BPP form for all images lacking alpha data.
There was some files moving at browser/extensions/pdfjs/components to remove pdf.js.components resource and XPCOMUtils.generateNSGetFactory.

Dave, are you the right person to review this change?
Attachment #8386164 - Flags: review?(dtownsend+bugmail)
Comment on attachment 8386164 [details] [diff] [review]
Update pdf.js to version 0.8.1114

Review of attachment 8386164 [details] [diff] [review]:
-----------------------------------------------------------------

r=me for the jsm and manifest changes
Attachment #8386164 - Flags: review?(dtownsend+bugmail) → review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/0c2a1ea6a296
Assignee: nobody → ydelendik
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0c2a1ea6a296
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Blocks: 978276
QA Whiteboard: [qa-]
Blocks: 871202
Depends on: 1374945
You need to log in before you can comment on or make changes to this bug.