Closed Bug 979953 Opened 6 years ago Closed 6 years ago

Tab titles shouldn't be bold on OS X

Categories

(Firefox :: Theme, defect)

30 Branch
x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: phlsa, Assigned: phlsa)

References

Details

(Whiteboard: [Australis:P4])

Attachments

(1 file, 1 obsolete file)

According to the spec, only the selected tab should have a bold title on OS X.
Unfortunately, this causes some odd behavior when switching tabs. So after talking with shorlander, we should just set the font weight of all tabs to normal. This is visually balanced and it also gives us a character or two of title text back.
Attached patch Patch v1 (obsolete) — Splinter Review
This removes the rule that makes the title text bold.
Attachment #8386213 - Flags: review?(mconley) → review+
Assignee: nobody → philipp
Attachment #8386213 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8386341 - Flags: review+
https://hg.mozilla.org/integration/fx-team/rev/32b670ea20d5
Keywords: checkin-needed
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/32b670ea20d5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 30
Boldification is gone now.
Vrified fixed 30.0a1 (2014-03-11), Mac OS X 10.8.5.
Status: RESOLVED → VERIFIED
Comment on attachment 8386341 [details] [diff] [review]
Patch v1.1 r=MattN

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis tabs redesign
User impact if declined: Tabs will look 'heavier' in Aurora, some small shifts when selecting one tab vs. another one
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): simple CSS fix, so none, I guess?
String or IDL/UUID changes made by this patch: none
Attachment #8386341 - Flags: approval-mozilla-aurora?
Attachment #8386341 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.