Closed Bug 980089 Opened 7 years ago Closed 7 years ago

this.contact is undefined error each time a contact is removed from the list displayed in the contacts window

Categories

(Instantbird :: Contacts window, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: florian)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch FixSplinter Review
Timestamp: 05/03/14 14:34:04
Error: TypeError: this.contact is undefined
Source File: chrome://instantbird/content/contact.xml
Line: 349

The problem is that in bug 970605 we replaced this.parentNode.removeChild(this) with this.remove(). Unfortunately, the contact and buddy bindings (and imcontact for Thunderbird) already had a remove method, and they now collide. The patch just renames these methods from 'remove' to 'delete'.
Attachment #8386419 - Flags: review?(clokep)
Comment on attachment 8386419 [details] [diff] [review]
Fix

This is a really unfortunate naming... Changes look good though.
Attachment #8386419 - Flags: review?(clokep) → review+
https://hg.mozilla.org/comm-central/rev/a5850f3ecb9a
Assignee: nobody → florian
Severity: normal → major
Status: NEW → RESOLVED
Closed: 7 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.6
Duplicate of this bug: 1007602
You need to log in before you can comment on or make changes to this bug.