Bookmarks do not save properly in multiple instances of Mozilla

VERIFIED DUPLICATE of bug 76431

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 76431
17 years ago
12 years ago

People

(Reporter: Isaac Curtis, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

Bookmarks do not save properly in multiple instances of Mozilla, particularly on
multiple desktops.  With two open browsers, even on the same desktop, a page
that is bookmarked in one browser window will not appear in the bookmarks of the
other window.  After you close all instances of Mozilla, the bookmarks that are
available at the next execution are the bookmarks of only one of the previous
instances.  This bug is a major impediment to online research as I never know
whether any of my bookmarks will or will not be saved when I am using more than
one browser, as one always does in research.  I appreciate the work of whoever
addresses this, and I am willing to test any nightly builds that come out which
attempt to resolve it.  Thank you for your time.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla on desktop 1 and wait for page to load
2. Open Mozilla on desktop 2 and wait for page to load
3. Go to www.heiroglyphics.com on desktop 1 and bookmark the site
4. Switch to desktop 2 and see that www.heiroglyphics.com has not been saved in
the Mozilla on desktop 2. Go to www.mozilla.org on desktop 2 and bookmark the site
6. Go to desktop 1 and see that www.mozilla.org has not been saved in the
Mozilla on desktop 1
7. Go to desktop 3 and open Mozilla
8. See that the bookmarks tab displays www.mozilla.org, the bookmarks from the
browser that most recently added a bookmark, but not www.heiroglyphics.com from
desktop 1
9. Quit (or close, it is indifferent with respect to this bug) Mozilla on desktop 3.
10. Go to desktop 1 and view www.anarchistfaq.org with the Mozilla browser
already open to www.heiroglyphics.com
11. When the page has finished loading, bookmark www.anarchistfaq.org
12. Go to desktop 3 and open Mozilla
13. See that the bookmarks tab displays www.heiroglyphics.com and
www.anarchistfaq.org, the bookmarks from the browser that most recently added a
bookmark, but not www.mozilla.org from desktop 2, even though the last time you
opened a browser on this desktop it inherited the bookmarks from desktop 2

Actual Results:  I nested the results in the previous section ("Steps to
Reproduce") because there were several results necessary to demonstrate the
specific nature of the bug.  The bug is also repeatable with multiple instances
of Mozilla on the same desktop.  If more than one browser window is already
open, the browsers will behave the same way as if they were on seperate
desktops.  They will inherit no bookmarks from one another and when a new
browser window is open it will inherit its bookmarks from the previously open
instance that most recently added another bookmark.

Expected Results:  When a page is bookmarked (or deleted/renamed/moved in
bookmarks) in Mozilla it should automatically appear in the bookmarks of all
instances of Mozilla on all desktops.

I am classifying this bug as normal severity because while bookmarking errors to
some are minor, it is a major hindrance to those doing online research and there
is no easy workaround because using only one browser window is a very
significant inconvenience.
This is a duplicate of the bug about the fact that it's possible to run two
separate instances of Mozilla with the same profile at all on Unix.  We should
have a lock file like NS 4.x does.

*** This bug has been marked as a duplicate of 76431 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 2

17 years ago
thanks boris.
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.