Closed Bug 980243 Opened 6 years ago Closed 6 years ago

Wrong display of OpenLayers GIS maps

Categories

(Core :: DOM: Core & HTML, defect)

27 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox27 --- wontfix
firefox28 - wontfix
firefox29 + fixed
firefox30 + fixed
firefox-esr24 --- unaffected

People

(Reporter: hattori, Assigned: bzbarsky)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140303165517

Steps to reproduce:

1. Open http://mapa-banska-bystrica.gisplan.sk/mapa/
2. When the first layer loads, choose one of the layers listed in the left panel, e.g. "Ortofotomapa 2012"
3. After the layer loads, click the "refresh button" represented by two blue arrows going in a circle. It is located in the left button panel - second icon from the bottom.


Actual results:

The layers completely disappear.


Expected results:

The layers shoud refresh and display again. The same happens with all layers - raster and vector
Severity: normal → critical
Component: Untriaged → Private Browsing
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2390cb215cc4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131010072645
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/3bc7ae253cdf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131010075449
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2390cb215cc4&tochange=3bc7ae253cdf
Regressed by:
	41e7e41afe1f	Mina Almasry — Bug 696451 - Reload <img> when crossOrigin attribute is set. r=bz
Blocks: 696451
Severity: critical → normal
Component: Private Browsing → DOM: Core & HTML
Keywords: regression
Product: Firefox → Core
Version: 28 Branch → 27 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmm.  This seems to be due to the "src set" logic moving from SetAttr to AfterSetAttr.

Interestingly, once we're in the broken state opening or closing devtools immediately fixes.  But just resizing the window does NOT fix.

Interestingly, removing the nodes from the DOM and then putting them back also doesn't fix.  So I'm not sure what the story is with the devtools bit there.

I'll try to poke at this a bit, but any information on what that "refresh" button is actually doing, or anything that creates a smaller testcase, would be very welcome!
Actually, nevermind.  I still don't know exactly why it's being an issue, but the move of the src set to AfterSetAttr was clearly wrong.  Patch, with comments, coming up.
Assignee: nobody → bzbarsky
Whiteboard: [need review]
I bet the page is watching for load events that never happen or something....
Though Chrome doesn't send load events for src sets to existing value.  So I'm really not sure what the deal is there.  :(
Jonas, since it's sort of your prompting that introduced the bug, you get to review the fix.  ;)
Attachment #8386827 - Flags: review?(jonas)
hattori@mad.scientist.com, thank you for the bug report!
> So I'm really not sure what the deal is there.  :(

And hence would still love a reduced-ish testcase.
Today is the final beta for FF28 and we've already lived with this in FF27 for almost 6 weeks, will have to track for FF29 at the earliest and try to get this regression fixed in time for that release - ideally early in Beta 29 cycle.
Comment on attachment 8386827 [details] [diff] [review]
Make sure that image src sets do something even if the src is being set to the value it already has.

Review of attachment 8386827 [details] [diff] [review]:
-----------------------------------------------------------------

This seems like the right thing to do, though it's not clear to me why it fixes the bug?
Attachment #8386827 - Flags: review?(jonas) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb77e0285652
Flags: in-testsuite+
Whiteboard: [need review]
Comment on attachment 8386827 [details] [diff] [review]
Make sure that image src sets do something even if the src is being set to the value it already has.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 696451
User impact if declined: Some sites do not work correctly
Testing completed (on m-c, etc.): Passes tests
Risk to taking this patch (and alternatives if risky): Moderate risk, somewhat
   mitigated by this being a reversion to the previous behavior we had in Firefox
   26.  The obvious other option is to let this ride the trains.
String or IDL/UUID changes made by this patch: None.

I don't think we want a beta 28 backport at this point, but if someone thinks we do please request beta approval....
Attachment #8386827 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/bb77e0285652
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Attachment #8386827 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.