Closed Bug 980569 Opened 6 years ago Closed 6 years ago

Bookmark star animation is misaligned after fixing bug 975807

Categories

(Firefox :: Theme, defect)

30 Branch
x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: phlsa, Assigned: phlsa)

References

Details

(Whiteboard: [Australis:P-])

Attachments

(1 file)

The fix for bug 975807 causes the bookmark star animation to end in the wrong place.
Attached patch Patch v1Splinter Review
This patch changes the keyframes of the keyframes of the animation so that it fits nicely with the dropmarker. Tested on Linux (and OS X for side effects).
Attachment #8387127 - Flags: review?(mconley)
Comment on attachment 8387127 [details] [diff] [review]
Patch v1

Review of attachment 8387127 [details] [diff] [review]:
-----------------------------------------------------------------

Tried, tested and true. This r+ is for you.

Thanks phlsa!
Attachment #8387127 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/043003505095
Keywords: checkin-needed
Whiteboard: [Australis:P-] → [Australis:P-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/043003505095
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P-][fixed-in-fx-team] → [Australis:P-]
Target Milestone: --- → Firefox 30
Comment on attachment 8387127 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Bug 975807


User impact if declined: 

The bookmark star animation will be slightly misaligned, which looks sloppy.


Testing completed (on m-c, etc.): 

Local testing.


Risk to taking this patch (and alternatives if risky): 

Very, very low.


String or IDL/UUID changes made by this patch:

None.
Attachment #8387127 - Flags: approval-mozilla-aurora?
Attachment #8387127 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.