Closed Bug 980854 Opened 7 years ago Closed 6 years ago

Remove the workaround for glitchy touch tones introduced implemented bug 917193

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S4 (12sep)

People

(Reporter: gsvelto, Assigned: gsvelto)

References

Details

(Whiteboard: [planned-sprint])

Attachments

(2 files, 1 obsolete file)

We implemented a workaround in bug 917193 that uses pre-recorded OPUS files instead of Web Audio-generated sounds for short touch tones, this should be removed as soon as bug 848954 is fixed and we can prove the glitches are not audible anymore.
With the dependencies finally fulfilled we can get rid of a lot of annoying workarounds (and unnecessary complexity). I've quickly tested this on my Flame and it works fine but I want to test it on the Hamachi too because we encountered this issue on that specific phone and due to its weaker hardware it was more likely to exhibit the glitchy sounds.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Whiteboard: [planned-sprint]
Target Milestone: --- → 2.1 S4 (12sep)
I haven't asked for review yet because I wanted to try this on the Hamachi but before being able to do that I have to fix a couple of regressions that made my Hamachi (and a lot of other people's ICS-based devices) unusable. One is bug 970751 which makes the main process die on an assertion when you tap the screen and the second is a huge spike in CPU usage in the main process. I'm bisecting that one right now :-/
I could finally test on my Hamachi, this seems to be working fine now, no glitches, no scratches.
Attachment #8480559 - Attachment is obsolete: true
Attachment #8483559 - Flags: review?(anthony)
Comment on attachment 8483559 [details] [diff] [review]
[PATCH v2] Remove the workarounds for glitchy touch tones now that bug 848954 has landed

Review of attachment 8483559 [details] [diff] [review]:
-----------------------------------------------------------------

It's a bit sad that it required no test changes.
Attachment #8483559 - Flags: review?(anthony) → review+
Tests on the device are looking good. I'm attaching the PR to get a Try run before landing this.
Green Try run here: https://tbpl.mozilla.org/?rev=1f613b5506b0553c0ccde6dff311a0cd524b0bf6&tree=Gaia-Try

Pushed to gaia/master 96179a39249d0d7c7fd3485001c596c31b296cec

https://github.com/mozilla-b2g/gaia/commit/96179a39249d0d7c7fd3485001c596c31b296cec
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 1073214
You need to log in before you can comment on or make changes to this bug.