Closed Bug 980907 Opened 6 years ago Closed 6 years ago

[ml, mr, kn, mai, ta, te, bn-IN, gu-IN, as, or] Add Indic locales to Fennec all-locales

Categories

(Firefox for Android :: General, defect)

30 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox29 --- fixed

People

(Reporter: gueroJeff, Assigned: gueroJeff)

References

Details

Attachments

(1 file, 1 obsolete file)

Currently pa-IN and hi-IN are already in Fennec all-locales. Please add the remaining Indic locales to mobile/android/locales/all-locales in order to allow them to test and track l10n work on Fennec.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8387575 - Flags: review?(l10n)
Attachment #8387575 - Flags: checkin?(l10n)
Attachment #8387575 - Flags: approval-mozilla-aurora?
Comment on attachment 8387575 [details] [diff] [review]
Patch to add Indic locales to mobile/android/locales/all-locales

Review of attachment 8387575 [details] [diff] [review]:
-----------------------------------------------------------------

r-, as this patch actually conflicts with bug 979260, which adds just 'ms'.

Canceling the other flags, too. Just talked to RyanVM on irc, the best way to get your patches landed is to request checkin after the patch has review and approval. Don't flag me in person, and one of us is gonna get to it.
Attachment #8387575 - Flags: review?(l10n)
Attachment #8387575 - Flags: review-
Attachment #8387575 - Flags: checkin?(l10n)
Attachment #8387575 - Flags: approval-mozilla-aurora?
Depends on: 979260
(In reply to Axel Hecht [:Pike] from comment #2)
> Comment on attachment 8387575 [details] [diff] [review]
> Patch to add Indic locales to mobile/android/locales/all-locales
> 
> Review of attachment 8387575 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r-, as this patch actually conflicts with bug 979260, which adds just 'ms'.
> 
> Canceling the other flags, too. Just talked to RyanVM on irc, the best way
> to get your patches landed is to request checkin after the patch has review
> and approval. Don't flag me in person, and one of us is gonna get to it.

Sounds good. I've added 979260 as a blocker to this bug so that I can request a review once the patch from 979260 lands.

Thank you!
Comment on attachment 8387575 [details] [diff] [review]
Patch to add Indic locales to mobile/android/locales/all-locales

Review of attachment 8387575 [details] [diff] [review]:
-----------------------------------------------------------------

Now that 979260 has landed, I'm flagging patch for new review.
Attachment #8387575 - Flags: review?(l10n)
Attachment #8387575 - Flags: review-
Attachment #8387575 - Flags: approval-mozilla-aurora?
Comment on attachment 8387575 [details] [diff] [review]
Patch to add Indic locales to mobile/android/locales/all-locales

Review of attachment 8387575 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry, but we'll need a new patch that doesn't try to add 'ms'. I expect that you'll get a merge conflict to resolve when you hg pull --rebase in your aurora repo.

PS: I would have just cleared the review if the patch had a chance to survive.
Attachment #8387575 - Flags: review?(l10n) → review-
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8387575 - Attachment is obsolete: true
Attachment #8387575 - Flags: approval-mozilla-aurora?
Attachment #8387664 - Flags: review?(l10n)
Attachment #8387664 - Flags: approval-mozilla-aurora?
Attachment #8387664 - Flags: review?(l10n) → review+
Attachment #8387664 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/0ffbd3bdf694
Assignee: nobody → jbeatty
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Flags: in-moztrap?(fennec)
You need to log in before you can comment on or make changes to this bug.