Closed Bug 981156 Opened 6 years ago Closed 6 years ago

Intermittent test_ipc.html | test_peerConnection_offerRequiresReceiveAudio.html | uncaught exception - TypeError: myPc.iceConnectionState is not a function at templates.js:150

Categories

(Core :: WebRTC, defect)

29 Branch
All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox28 --- unaffected
firefox29 --- unaffected
firefox30 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: KWierso, Assigned: drno)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=35812918&tree=Mozilla-Central
slave: tst-linux64-spot-652



13:34:32     INFO -  (stun/INFO) STUN-CLIENT(srflx(IP4:10.132.156.244:45315/UDP|stun.services.mozilla.com:3478)): Timed out
13:34:32     INFO -  JavaScript error: http://mochi.test:8888/tests/dom/media/tests/mochitest/templates.js, line 150: myPc.iceConnectionState is not a function
13:34:32     INFO -  (stun/INFO) STUN-CLIENT(srflx(IP4:10.132.156.244:56852/UDP|stun.services.mozilla.com:3478)): Timed out
13:34:32     INFO -  41 INFO TEST-INFO | dumping last 15 message(s)
13:34:32     INFO -  42 INFO TEST-INFO | if you need more context, please use SimpleTest.requestCompleteLog() in your test
13:34:32     INFO -  43 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | Got first iframe load event.
13:34:32     INFO -  44 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | Got second iframe load event.
13:34:32     INFO -  45 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  iceConnectionState starts at 'new'
13:34:32     INFO -  46 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  iceConnectionState starts at 'new'
13:34:32     INFO -  47 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  Initial local signalingState is 'stable'
13:34:32     INFO -  48 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  Initial remote signalingState is 'stable'
13:34:32     INFO -  49 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  Local create offer does not change signaling state
13:34:32     INFO -  50 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  signalingState after local setLocalDescription is 'have-local-offer'
13:34:32     INFO -  51 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  signalingState after remote setRemoteDescription is 'have-remote-offer'
13:34:32     INFO -  52 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  Remote createAnswer does not change signaling state
13:34:32     INFO -  53 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  iceConnectionState should not be undefined
13:34:32     INFO -  54 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  signalingState after local setRemoteDescription is 'stable'
13:34:32     INFO -  55 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  iceConnectionState should not be undefined
13:34:32     INFO -  56 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  signalingState after remote setLocalDescription is 'stable'
13:34:32     INFO -  57 INFO TEST-PASS | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  iceConnectionState should not be undefined
13:34:32     INFO -  58 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/ipc/test_ipc.html | /tests/dom/media/tests/mochitest/test_peerConnection_offerRequiresReceiveAudio.html |  uncaught exception - TypeError: myPc.iceConnectionState is not a function at http://mochi.test:8888/tests/dom/media/tests/mochitest/templates.js:150
13:34:32     INFO -  ++DOMWINDOW == 8 (0x130a340) [pid = 2557] [serial = 75] [outer = 0x11d6bd0]
13:34:32     INFO -  -2124711488[6ca300]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:1596: CloseInt: Closing PeerConnectionImpl af4e776a6b2d8d43; ending call
13:34:32     INFO -  1754326784[7ff764011990]: [CCAPP Task|def] ccapi.c:1445: SIPCC-CC_API: 1/37, cc_int_onhook: UI -> GSM: ONHOOK
13:34:32     INFO -  1754326784[7ff764011990]: [CCAPP Task|def] ccapi.c:1447: (1/37) On-hook called from /builds/slave/m-cen-l64-d-000000000000000000/build/media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:657
13:34:32     INFO -  1746900736[7ff758001400]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
13:34:32     INFO -  1746900736[7ff758001400]: [GSM Task|fsm_sm] sm.c:46: SIPCC-FSM: sm_process_event: DEF 37  : 0x7ff77ca06ce2x: sm entry: (STABLE:ONHOOK)
13:34:32     INFO -  1746900736[7ff758001400]: [GSM Task|fsm_sm] fsmdef.c:6711: SIPCC-FSM: fsmdef_ev_onhook: Entered.
13:34:32     INFO -  1746900736[7ff758001400]: [GSM Task|fsm_sm] fsmdef.c:1986: SIPCC-FSM: 1/37, fsmdef_release: Entered. cause= NORMAL
Nils: can you look into this and see what's going on?  Thanks
Flags: needinfo?(drno)
This contains one bug I introduced recently...
Assignee: nobody → drno
Status: NEW → ASSIGNED
Flags: needinfo?(drno)
Attachment #8389550 - Flags: review?(rjesup) → review+
Duplicate of this bug: 981037
https://hg.mozilla.org/mozilla-central/rev/8b13d02000f4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.