Closed Bug 981244 Opened 7 years ago Closed 7 years ago

Browser customizations (in particular bookmarks) appear broken on 1.4

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

defect
Not set
normal

Tracking

(blocking-b2g:1.4+)

RESOLVED WORKSFORME
1.4 S4 (28mar)
blocking-b2g 1.4+

People

(Reporter: jhammink, Assigned: albert)

Details

(Keywords: regression, Whiteboard: [systemsfe], burirun1.4-1)

Attachments

(1 file)

49.53 KB, application/json
Details
Attached file browser.json
Gaia      f692ee0e21ef4e25ec501d60226aa7da4b06ae60
Gecko     https://hg.mozilla.org/mozilla-central/rev/7a2edc5171e6
BuildID   20140307160201
Version   30.0a1
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013
base image: 1.2-device.cfg

STR:

1.) Flash the latest build for the version you are aiming to test
2.) Set up your reference customization as according to bug 980149.
3.) Note that the reference contains the attached browser.json.
4.) I flashed the customization on each of No SIM, AT&T, T-Mobile, and Movistar SIMs.  For each SIM & No SIM, I then repeated steps 1-4.
5.)  I then checked the browser bookmarks on each customization.
 
Expected:  
No Sim:  Facebook
AT&T: Facebook
T-Mobile:  YouTube, Facebook
Movistar:  Movistar.es, El Mundo, Yavoy

Actual:   
No Sim:  Facebook
AT&T: Facebook
T-Mobile: Facebook
Movistar: Facebook

As the documentation is incomplete, it's entirely possible that my reference customization is missing some piece, so please advise me if I should check/change/add/edit something somewhere.
A perception issue, so may or may not be blocking.  Possible regression also, so nomming.
blocking-b2g: --- → 1.4?
No longer depends on: 980149
Whiteboard: [systemsfe], burirun1.3-1 → [systemsfe], burirun1.4-1
Component: Gaia::System → Gaia::Browser
Marce, can you take a look here?
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(marce)
Gregor, this bug looks like a bug for v1.2 (base image is 1.2-device.cfg) so it shoudn't be 1.4+, could you check again?
Flags: needinfo?(anygregor)
(In reply to Yuren [:yurenju][:小朱] from comment #3)
> Gregor, this bug looks like a bug for v1.2 (base image is 1.2-device.cfg) so
> it shoudn't be 1.4+, could you check again?

This bug is for 1.4 & was working on 1.2 & 1.3. This is a supported feature for partner customizations. So I'm not sure what you are implying here?
base image from comment 0 confused me, nerver mind.
Flags: needinfo?(anygregor)
use |GAIA_DISTRIBUTION_DIR=customization/ make| to test it and got correct js/init.json in zip file of browser app.
Assignee: nobody → acperez
Flags: needinfo?(marce)
Yes, Albert will take it
I tried to reproduce it with 1.3 and 1.4 and both worked fine, all bookmarks are the expected for each SIM case.

Are you sure the mcc/mnc of the SIM cards you are using are the expected ones?
Flags: needinfo?(jhammink)
leaving qawanted to retest on the latest 1.4 build
Keywords: qawanted
Target Milestone: --- → 1.4 S4 (28mar)
I am unable to reproduce this on latest Buri v1.4, each case gave the expected results.

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140317040204
Gaia: 7ec890587c0669a08015920a88570b6d4f74894c
Gecko: 25cfa01ba054
Version: 30.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: pbylenga
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jhammink)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.