Closed Bug 981306 Opened 7 years ago Closed 5 years ago

CSS transition animation lags with document.body or document.body.parentNode

Categories

(Core :: Layout, defect)

19 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox-esr24 --- affected

People

(Reporter: mgalli, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

Attachments

(1 file)

This seems to be a regression for me since I recall it used to have a smooth transition. The case is when you apply a scale transformation, with animation (CSS transition) to the body or the documentElement. 

My testcase: 
http://www.mgalli.com/development/transitionbody/doctrans.html

Expect: 
Smooth animation. 

What happens: 
Lags/breaks. 

Use case: some apps may attempt to apply transformations to the HTML and body tag so they can create camera effects (video observation) without the need of adding extra tags to the markup. This allows for a zoom in/out navigation model.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Status: UNCONFIRMED → NEW
Component: CSS Parsing and Computation → Layout
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0d771761b9b3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121230 Firefox/20.0 ID:20121230093651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e7eb5d695818
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121230 Firefox/20.0 ID:20121230144652
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0d771761b9b3&tochange=e7eb5d695818

Regressed by: Bug 816359
Blocks: 816359
Version: unspecified → 19 Branch
Assignee: nobody → matt.woodrow
Also noticed when you take away the overflow:hidden, it smooths better: 

http://www.mgalli.com/development/transitionbody/red2.html
Firefox: 45.0.1, Build ID: 20160315153207
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Hi Galli,

I have tested this issue on the latest Firefox (45.0.1) release, latest Nightly (48.a01 - Build ID: 20160322030417) build bud I could not reproduce it. I have used the provided test cases from comment 1 and comment 3, but the animation has no lag. 

Is this still reproducible on your end ? If yes, can you please retest this using latest Firefox release and latest Nightly build (https://nightly.mozilla.org/)and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E). 

Thanks,
Cosmin.
Flags: needinfo?(mgalli)
Considering the fact that I cannot reproduce this and the fact that the reporter did not answered to my request until now, I will mark this as Resolved-Worksforme.
If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks,
Cosmin.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mgalli)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.