Closed Bug 981468 Opened 7 years ago Closed 7 years ago

[Sora][Call] [MPTY] Can't hide keypad during a multiparty call.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

defect

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

VERIFIED FIXED
1.4 S4 (28mar)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: sync-1, Assigned: etienne)

References

()

Details

Attachments

(3 files)

275.74 KB, application/octet-stream
Details
480.93 KB, application/octet-stream
Details
46 bytes, text/x-github-pull-request
ferjm
: review+
Details | Review
Firefox OS v1.3
 Mozilla build ID: 20140226004002
 
 Created an attachment (id=659959)
 Logcat for this PR
 
 DEFECT DESCRIPTION:
  User can't hide keypad during a multiparty call.
 
  REPRODUCING PROCEDURES:
  1. Idle -> Enter " Phone " App -> Establish a Call(10010) -> Tap "Add call" icon -> Establish the second call(10086) -> Merge the two calls -> Open the keypad during the multiparty call -> Hide the keypad -> Can't hide the keypad(K.O)
 
 
  EXPECTED BEHAVIOUR:
  User can hide keypad during a multiparty call.
 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
  100%
 
  For FT PR, Please list reference mobile's behavior:
Attached file Logcat for this PR
Confirmed can still reproduce this issue on Moz build 20140305040055.

Thanks

Vance
Hi Vance,

During multiparty call, display the keypad, input some numbers, the numbers can not be displayed. Please check also. Thanks! :)
(In reply to Mingming ZHAO from comment #4)
> Hi Vance,
> 
> During multiparty call, display the keypad, input some numbers, the numbers
> can not be displayed. Please check also. Thanks! :)

That sounds like a different bug - can you open a new bug for that?

This is basic bustage, so I'm nominating this.
blocking-b2g: --- → 1.3?
Just adding that once we open the keypad during the multiparty call, not only we can not hide it, besides we can not enter in the Group detail so we can not hang up to a unique participant and continue the conversation with the rest, we need to hang up all of them at the same time what it's even worse.
David,

Please help review and reassign.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(dscravaglieri)
Etienne, could you reproduce this bug ?
Flags: needinfo?(dscravaglieri) → needinfo?(etienne)
(In reply to David Scravaglieri [:scravag] from comment #8)
> Etienne, could you reproduce this bug ?

Yes, taking.
Flags: needinfo?(etienne)
Attached file Gaia PR
We had JS errors occurring in this case. This patch fixes them and lets you hide the keyboard properly.

Also when the keypad is active the rest of the screen isn't actionable (by design), so hiding the conference group disclosure button when the keypad is displayed since it's not actionable.
Attachment #8389790 - Flags: review?(ferjmoreno)
Assignee: nobody → etienne
Duplicate of this bug: 982832
Comment on attachment 8389790 [details] [review]
Gaia PR

Sorry for the late review, Etienne.

LGTM. r=me
Attachment #8389790 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/36b470c47daed3c763f6e263e4b3f57be1828fae
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8389790 [details] [review]
Gaia PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): conference call support
[User impact] if declined: see Description
[Testing completed]: manually tested with 1 call, 2 calls and 1 conference call + unit tested
[Risk to taking this patch] (and alternatives if risky): pretty low
[String changes made]: none
Attachment #8389790 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8389790 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
v1.3: 2ea2aab306bd1c941719160cdcb49ee9d755dc17
Target Milestone: --- → 1.4 S4 (28mar)
Tested and working
1.3
Platform version: 28.0
Build ID: 20140319100231
Git commit: f2f2be55

1.4
Platform version: 30.0a2
Build ID: 20140319105930
Git commit: c036afe
Status: RESOLVED → VERIFIED
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.