dns cache grace period error busting too aggressive

RESOLVED FIXED in Firefox 29

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mcmanus, Assigned: mcmanus)

Tracking

unspecified
mozilla30
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 fixed, firefox30 fixed)

Details

(Whiteboard: [dns])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #981447 +++

see 981447 for background

this is a revert of the 807441. a followup bug will come out of 981447 for a strategy that takes into accounts a "valid host, but invalid ssl" name switch. (especially driven from chrome)
Posted patch revert 807441Splinter Review
Attachment #8388367 - Flags: review?(sworkman)
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED
Attachment #8388367 - Flags: review?(sworkman) → review+
Comment on attachment 8388367 [details] [diff] [review]
revert 807441

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 807441
User impact if declined: unable to see websites with updated DNS information under some circumstances
Testing completed (on m-c, etc.): verified by hand, verified by reporter, on m-i 
Risk to taking this patch (and alternatives if risky): low - one line of logic changed and reverted to an old state
String or IDL/UUID changes made by this patch: none
Attachment #8388367 - Flags: approval-mozilla-aurora?
Comment on attachment 8388367 [details] [diff] [review]
revert 807441

Review of attachment 8388367 [details] [diff] [review]:
-----------------------------------------------------------------

must be uplifted for fx/a
Attachment #8388367 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/74e388697888
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 861273
You need to log in before you can comment on or make changes to this bug.