Double click folder in right side pane does not work

RESOLVED FIXED in mozilla30

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alice0775, Assigned: mak)

Tracking

({regression})

30 Branch
mozilla30
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox29 unaffected, firefox30- affected)

Details

Attachments

(1 attachment)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/21f293fc8d34
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140309030204

Steps To Reproduce:
1. Open Library Ctrl+Shift+B
2. Double click folder in right side pane

Actual Results:
Nothing happens
Regression(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/78fa90a29c43
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140304114257
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/722fd1b0e050
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140304124457
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=78fa90a29c43&tochange=722fd1b0e050
Regressed by:
722fd1b0e050	Marco Bonardo — Bug 435851 - dragging a folder shortcut drags the concrete folder instead. r=mano
Blocks: 435851
Component: Bookmarks & History → Places
Product: Firefox → Toolkit
This problem happens with the following condition:
1. Selected parent folder in left side pane is collapsed.
2. Then, Child folder listed in right side pane cannot expand.

In other words, If parent folder in left side pane is expanded , child folder listed in right side pane can expand by double click.
it's due to changed behavior of selectItems (that is actually intended as a perf improvement).
The openFlatContainer method should first ensure to open the currently left pane selected container. I should also add a test for this.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: in-testsuite?
Posted patch patch v1Splinter Review
Attachment #8389156 - Flags: review?(mano)
https://hg.mozilla.org/integration/fx-team/rev/56ac183ad1e2

At this point doesn't make sense to spend triage time on this
No longer blocks: fxdesktoptriage
Flags: in-testsuite? → in-testsuite+
Target Milestone: --- → mozilla30
https://hg.mozilla.org/mozilla-central/rev/56ac183ad1e2
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.