Closed Bug 981614 Opened 6 years ago Closed 6 years ago

crash in java.lang.NullPointerException: at org.mozilla.gecko.home.HomePager.onToolbarFocusChange(HomePager.java)

Categories

(Firefox for Android :: General, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
fennec 29+ ---

People

(Reporter: aaronmt, Assigned: lucasr)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-2ec3b1a3-9733-4fc3-8305-eef802140309.
=============================================================

java.lang.NullPointerException
	at org.mozilla.gecko.home.HomePager.onToolbarFocusChange(HomePager.java:255)
	at org.mozilla.gecko.BrowserApp$12.onFocusChange(BrowserApp.java:520)
	at org.mozilla.gecko.toolbar.BrowserToolbar$5.onFocusChange(BrowserToolbar.java:320)
	at org.mozilla.gecko.toolbar.ToolbarEditLayout$3.onFocusChange(ToolbarEditLayout.java:74)
	at android.view.View.onFocusChanged(View.java:4600)
	at android.widget.TextView.onFocusChanged(TextView.java:7652)
	at android.widget.EditText.onFocusChanged(EditText.java:178)
	at org.mozilla.gecko.toolbar.ToolbarEditText.onFocusChanged(ToolbarEditText.java:110)
	at android.view.View.handleFocusGainInternal(View.java:4405)
	at android.view.View.requestFocusNoSearch(View.java:6626)
	at android.view.View.requestFocus(View.java:6605)
	at android.view.View.requestFocus(View.java:6572)
	at android.view.View.requestFocus(View.java:6551)
	at org.mozilla.gecko.toolbar.ToolbarEditLayout$4.onPropertyAnimationStart(ToolbarEditLayout.java:139)
	at org.mozilla.gecko.animation.PropertyAnimator.start(PropertyAnimator.java:184)
	at org.mozilla.gecko.BrowserApp.enterEditingMode(BrowserApp.java:1516)
	at org.mozilla.gecko.BrowserApp.enterEditingMode(BrowserApp.java:1495)
	at org.mozilla.gecko.BrowserApp.access$500(BrowserApp.java:100)
	at org.mozilla.gecko.BrowserApp$8.onActivate(BrowserApp.java:494)
	at org.mozilla.gecko.toolbar.BrowserToolbar$1.onClick(BrowserToolbar.java:237)
	at android.view.View.performClick(View.java:4232)
	at android.view.View$PerformClick.run(View.java:17298)
	at android.os.Handler.handleCallback(Handler.java:615)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4921)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1027)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:794)
	at dalvik.system.NativeStart.main(Native Method)

This is a rising crash signature these past few days.
Flags: needinfo?(lucasr.at.mozilla)
Duplicate of this bug: 981624
Comment on attachment 8388528 [details] [diff] [review]
Do a null check when handling toolbar focus change in HomePager (r=jdover)

It seems we might get a focus change before the banner is set?
Attachment #8388528 - Flags: review?(jdover)
Flags: needinfo?(lucasr.at.mozilla)
Assignee: nobody → lucasr.at.mozilla
Duplicate of this bug: 981616
tracking-fennec: --- → 29+
Comment on attachment 8388528 [details] [diff] [review]
Do a null check when handling toolbar focus change in HomePager (r=jdover)

Review of attachment 8388528 [details] [diff] [review]:
-----------------------------------------------------------------

Ah yes I was going to add this check in bug 966047, but we switched approaches and it never made it back in.
Attachment #8388528 - Flags: review?(jdover) → review+
Comment on attachment 8388528 [details] [diff] [review]
Do a null check when handling toolbar focus change in HomePager (r=jdover)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 920791
User impact if declined: Crasher when toolbar enters/leaves editing mode
Testing completed (on m-c, etc.): local testing only, let's bake this in m-c for a day or two then uplift.
Risk to taking this patch (and alternatives if risky): very low, just a null check. 
String or IDL/UUID changes made by this patch: n/a
Attachment #8388528 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e1f1f275f902
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8388528 [details] [diff] [review]
Do a null check when handling toolbar focus change in HomePager (r=jdover)

A day after, approving.
Attachment #8388528 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I'm confused, bug 920791 didn't land on 29? And indeed, this patch doesn't apply to Aurora.
Blocks: 920791
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #10)
> I'm confused, bug 920791 didn't land on 29? And indeed, this patch doesn't
> apply to Aurora.

Well that was an oversight! I'm going to nom that now.
Flags: needinfo?(lucasr.at.mozilla)
You need to log in before you can comment on or make changes to this bug.