Closed Bug 981653 Opened 6 years ago Closed 5 years ago

transitions between tracks are visually abrupt, should be smoother

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1126466

People

(Reporter: dietrich, Assigned: squib)

References

Details

(Whiteboard: [priority])

Clone of bug 962439 to fix this issue on master, not just Tarako.

Need UX feedback on the right behavior and transition.

+++ This bug was initially created as a clone of Bug #962439 +++

Looks like maybe it goes to a full black screen before fading in the next track's album art.

In the case where the album is the same, we should not do anything.

In the case where the album is different, we should do a fancy transition, and not start from black background.
Whiteboard: [priority]
It will probably be easier to fix this issue after bug 841949 lands, since I reworked how album art is stored there.
Taking this, since bug 841949 should land really soon.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
This is being fixed in bug 1126466.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126466
You need to log in before you can comment on or make changes to this bug.