Closed Bug 981666 Opened 6 years ago Closed 2 years ago

empty tiles visible even though they won't be used (changing topsites.maxresults pref)

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect)

x86
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: kjozwiak, Unassigned)

References

Details

(Whiteboard: [triage] p=0)

Attachments

(2 files)

When someone sets the browser.display.startUI.topsites.maxresults pref to a small number, we are still displaying "blank tiles" under that category. We should probably check and remove those if they aren't going to be used. I've attached two screenshots to illustrate the issue.

- emptyTiles1.png (set the pref to three but all the empty tiles are still visible)
- emptyTiles2.png (set the pref to one but all the empty tiles are still visible)

Steps to reproduce the issue:

1) Open fxmetro
2) Once opened, go to about:config and find "browser.display.startUI.topsites.maxresults"
3) Change the pref to something small, three should do the trick!
4) Go back into the about:start and you'll see three valid tiles and than a bunch of empty tiles

Current Behavior:

- Empty tiles are visible that won't be used when someone sets the topsites.maxresults to something smaller

Expected Behavior:

- We should only display the number of tiles that user has selected and NOT include empty tiles as those will always appear empty and take up screen real estate.

Issue found using the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-10-03-02-01-mozilla-central/
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.