Trunk crashes [@ nsMultiMixedConv::FindToken]

RESOLVED DUPLICATE of bug 100595

Status

()

--
critical
RESOLVED DUPLICATE of bug 100595
17 years ago
17 years ago

People

(Reporter: dbaron, Assigned: neeti)

Tracking

({crash, topcrash})

Trunk
x86
Other
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

There are still reports of crashes in talkback at nsMultiMixedConv::FindToken,
line 973.  Typical stack:

nsMultiMixedConv::FindToken
[d:\builds\seamonkey\mozilla\netwerk\streamconv\converters\nsMultiMixedConv.cpp,
line 973]
nsMultiMixedConv::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\streamconv\converters\nsMultiMixedConv.cpp,
line 463]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 242]
nsHttpChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2232]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 188]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072] 

User comments:

(34905152) Bugzilla again! I mean, how are we supposed to report bugs if buzilla
makes mozilla crash all the time?? It rarely crashes on other sites... Maybe
it's just my build?
(34868197) Clicked on a link to view a pdf-file. The window went blank, showed
the correct URL and then crash. Acrobat never loaded (no splash-screen was shown).
(34895768) Often crashes when I press back from a bugzilla bug page (this time
was Bug#:8589)

See also bug 81682 for previous crashes with this stack.
I think it looks like |aCursor| is null (which is different from the last crash,
where |token| was null), since the crash is on the first of the following
instructions, with edi=00000000:

6083d5e4 3a17             cmp     dl,[edi]
6083d5e6 750f             jnz     6083d5f7
6083d5e8 50               push    eax
6083d5e9 51               push    ecx
6083d5ea 57               push    edi
6083d5eb e8847d0100       call    60855374
(A crash reported as line 973 would really be something on line 972.)

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 2

17 years ago
Adding topcrash keyword.  Cc'ing Talkback folk.
Keywords: topcrash
Summary: crashes [@ nsMultiMixedConv::FindToken] → Trunk crashes [@ nsMultiMixedConv::FindToken]
This should be a dupe of bug 100595...


*** This bug has been marked as a duplicate of 100595 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ nsMultiMixedConv::FindToken]
You need to log in before you can comment on or make changes to this bug.