change event should be fired before submit event

VERIFIED DUPLICATE of bug 99350

Status

()

VERIFIED DUPLICATE of bug 99350
17 years ago
4 years ago

People

(Reporter: hjtoi-bugzilla, Assigned: joki)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

From an email:

onchange vs. onsubmit. If you change an input in a form and then
submit, the onchange event should fire before the onsubmit does. This
gives you a chance to validate the data before it is exported. In this
sample, onsubmit fires first, which is wrong.

<HTML><HEAD><TITLE>Test 1</TITLE></HEAD>
<BODY>
<form onsubmit="alert('submit');return false;">
<input type="text" name="a" onchange="alert('onchange');return true;">
Submit <input type="submit" name="Submit" value="Submit">
</form>
</BODY>
</HTML>

NS4 and IE5.5 do the onchange first. NS6.1 does the onsubmit first.
Keywords: 4xp
(Assignee)

Comment 1

17 years ago
duping on 99350.  That bug is newer but has more description.

*** This bug has been marked as a duplicate of 99350 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verifying
Status: RESOLVED → VERIFIED
Duplicate of this bug: 988629
You need to log in before you can comment on or make changes to this bug.