Closed Bug 982001 Opened 9 years ago Closed 8 years ago

Build failure - memory/mozalloc - fatal error: prenv.h: No such file or directory

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla30

People

(Reporter: stransky, Unassigned)

References

Details

My mozconfig & latest trunk:

. $topsrcdir/browser/config/mozconfig

ac_add_options --enable-default-toolkit=cairo-gtk2
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir
ac_add_options --enable-crashreporter
ac_add_options --without-system-nspr
ac_add_options --without-system-nss
ac_add_options --enable-debug
ac_add_options --disable-optimize

fails to build with:

c++ -o TestVolatileBuffer.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include /home/komat/tmp984-trunk/src/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DNO_NSPR_10_SUPPORT -I/home/komat/tmp984-trunk/src/memory/mozalloc/tests -I.  -I../../../dist/include  -I/home/komat/tmp984-trunk/src/objdir/dist/include/nspr -I/home/komat/tmp984-trunk/src/objdir/dist/include/nss    -I/usr/include/pixman-1    -I../../../dist/include/testing  -fPIC   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MP -MF .deps/TestVolatileBuffer.o.pp  -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Werror=int-to-pointer-cast -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -gdwarf-2 -fpermissive -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe  -DDEBUG -D_DEBUG -DTRACING -g -fno-omit-frame-pointer      /home/komat/tmp984-trunk/src/memory/mozalloc/tests/TestVolatileBuffer.cpp
In file included from ../../../dist/include/testing/TestHarness.h:25:0,
                 from /home/komat/tmp984-trunk/src/memory/mozalloc/tests/TestVolatileBuffer.cpp:5:
../../../dist/system_wrappers/prenv.h:3:24: fatal error: prenv.h: No such file or directory
Looks like $(objdir)/dist/include/nspr is missing.
Looks like a dupe of Bug 981162.
Looks like "--without-system-nspr" has been replaced by "--enable-nspr-build" but it still fails.
Well, "--enable-nsprpub" seems to do the trick here.
Blocks: 975011
Summary: Build failure - fatal error: prenv.h: No such file or directory → Build failure - memory/mozalloc - fatal error: prenv.h: No such file or directory
Hm, false alarm, even "--enable-nsprpub" does not help. Latest trunk still fails to build with in-tree nspr.
That was fixed by the backout of bug 975011. Hopefully, the new patch there won't introduce the same breakage.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.