Closed Bug 982022 Opened 6 years ago Closed 6 years ago

Page helper application icon is no longer displayed in the URL bar (Aurora 29.0)

Categories

(Firefox for Android :: General, defect)

29 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- verified
firefox30 --- unaffected
fennec 29+ ---

People

(Reporter: cos_flaviu, Assigned: wesj)

Details

(Keywords: regression, reproducible)

Attachments

(1 file, 1 obsolete file)

Environment: 
Device: Google Nexus 5 (Android 4.4.2);
Build: Aurora 29.0a2 (2014-03-10);

Steps to reproduce:
1. Go to m.youtube.com or maps.google.com;
3. Check if the helper app is present.

Expected result:
The helper app is present in the url bar.

Actual result:
The helper app is not present in the url bar.

Note:
Not reproducible on latest Nightly build.
tracking-fennec: --- → ?
Flags: needinfo?(esawin)
Flags: needinfo?(flaviu.cos)
Regression window made on aurora builds:
Last good build: 2014-02-24
First bad build: 2014-02-25

Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=f8ec94d3ab7c&tochange=2d1f9c800085
Flags: needinfo?(flaviu.cos)
Keywords: reproducible
I get a similar range http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=744c8107734f&tochange=f8ec94d3ab7c

This is reproducible.

Nothing really stands out :/
Summary: Helper app is no longer displayed in the url bar → Page helper application icon is no longer displayed in the URL bar (Aurora 29.0)
Flags: needinfo?(wjohnston)
Attached patch Patch (obsolete) — Splinter Review
We didn't need to override this. This code is a little (a lot) dangerous, but its all gone on central now :)
Attachment #8389646 - Flags: review?(rnewman)
Flags: needinfo?(wjohnston)
Flags: needinfo?(esawin)
Comment on attachment 8389646 [details] [diff] [review]
Patch

Review of attachment 8389646 [details] [diff] [review]:
-----------------------------------------------------------------

I will take your word for it :)
Attachment #8389646 - Flags: review?(rnewman) → review+
Attached patch PatchSplinter Review
Whoops. Removed something necessary while cleaning up my logging :)
Attachment #8389646 - Attachment is obsolete: true
Attachment #8389650 - Flags: review?(rnewman)
Comment on attachment 8389650 [details] [diff] [review]
Patch

Review of attachment 8389650 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, now it becomes clearer :)
Attachment #8389650 - Flags: review?(rnewman) → review+
Comment on attachment 8389650 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 917942
User impact if declined: Helper Apps are busted (and probably some other things)
Testing completed (on m-c, etc.): Tested locally. We've changed this code significantly on central so that this isn't needed there.
Risk to taking this patch (and alternatives if risky): Low risk. Just using the parent classes (exactly same) implementation
String or IDL/UUID changes made by this patch: none.
Attachment #8389650 - Flags: approval-mozilla-aurora?
Attachment #8389650 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-fennec: ? → 29+
Assignee: nobody → wjohnston
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Verified fixed on Aurora 30.0a2 (2014-04-02)
Doesn't reproduce on Firefox 29 Beta 4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.