-ProfileManager option doesn't bring up UI in QuickLaunch mode if ony 1 profile

VERIFIED INVALID

Status

Core Graveyard
Profile: BackEnd
VERIFIED INVALID
16 years ago
2 years ago

People

(Reporter: ji, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
mozilla0.9.4
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 090400
OS: Win XP RC1 Ja

On Windows XP, running browser with profilemanager option on command prompt
doesn't bring up profilemanager window.

Steps to reproduce:
1. Open commmand prompt window.
2. Go to the folder where the executable is located.
3. Run command, like "netscp6.exe -profilemanager", it doesn't bring up  Profile
Manager window.

I don't see this problem on W2K and win98.
(Reporter)

Comment 1

16 years ago
It only happens when there is only one existing profile.

Comment 2

16 years ago
It should still bring up the Profile Manager- do you have turbo/quick launch on? 
(Reporter)

Comment 3

16 years ago
I see this problem with Quick Launch turned off, which is the default option.
With Quick Launch turned on, profile manager can be launched even with only one
existing profile.

Comment 4

16 years ago
I'm having the same problem with 95 OSR2. I only have one profile (which is why
I want to bring up Profile Manager, to create/import more).

Comment 5

16 years ago
Nominating for nsbranch.
Keywords: nsbranch
Summary: ProfileManager option doesn't bring up profile manager window on XP → WinXP: ProfileManager option doesn't bring up profile manager window on XP

Comment 6

16 years ago
I cannot reproduce this on XP 2600
I had a clean system - no Netscape 4.x profiles, no 6.x profiles
Installed build for 9/7
Netscape launched with default profile as expected
brought up DOS window
ran netscp6 -profilemanager from install directory

launched with Profile Manager

I can reproduce if I have pref set for turbo and turbo is running
(Reporter)

Comment 7

16 years ago
Grace. can you reproduce when there is only one profile with quick launch is 
turned off?
My case is: I have one 4.x profile first, then run 6.x converts the 4.x profile 
to 6.x profile, after that I'm unable to bring up profile manager. I have to 
turn on quick launch or have another 4.x profile.

Comment 8

16 years ago
I cannot reproduce unless I have turbo(QuickLaunch) turned on
I don't think it makes a difference if the profile is migrated or not- as long 
as only one profile exists- 

adding Conrad to cc list as he may have some insights to turbo behavior 
and its affect on profilemanager option
(Reporter)

Comment 9

16 years ago
Now I can only reproduce this problem with quick launch enabled, same as Grace.
But I did see this problem with quick launch turned off, since when I reported
this bug, I ran 6.x with a profile migrated from 4.x, and quick launch is turned
off by default with a migrated profile. Something must have happened when I
played with quick launch feature.
(Assignee)

Comment 10

16 years ago
Found the problem and the fix is in patch for bug 88844.

The problem as I found it and fixed it was this: After the initial launch with
Quicklaunch (which may have happened at Windows startup time), if you had only 1
profile, launching again with -profilemanager did not bring up the profile mgr
UI. It worked properly if you had > 1 profile at the time of the initial launch.
Depends on: 88844
(Assignee)

Comment 11

16 years ago
Changing summary because has nothing to do with XP and changing component to
back end.
Assignee: ben → ccarlen
Component: Profile Manager FrontEnd → Profile Manager BackEnd
Summary: WinXP: ProfileManager option doesn't bring up profile manager window on XP → -ProfileManager option doesn't bring up UI in QuickLaunch mode if ony 1 profile
(Assignee)

Comment 12

16 years ago
-> 0.9.4 Not that it really matters because it will be fixed by bug 88844 but
keeping this one alive since it's valid and not a dup.
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 13

16 years ago
Fixed by check-in of bug 88844. That bug is not marked as checked in, but it is
(2001-09-10 16:47).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: ktrina → andreasb

Comment 14

16 years ago
I can't verify this without a Japanese OS. Can someone with Win XP RC1 Ja please 
verify this for me? 

Note: Changing QA Contact to Andreas
(Reporter)

Comment 15

16 years ago
QA contact to myself.
QA Contact: andreasb → ji
(Reporter)

Comment 16

16 years ago
With 09-11-05 0.9.4 build, this still happens with quick launch enabled.
Reopened.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 17

16 years ago
Peter/Sol - If Turbo is in, we should nsbranch+ all related bugs required to
meet the requirements for this round.
(Assignee)

Comment 18

16 years ago
> With 09-11-05 0.9.4 build

If you're talking about the branch build, yes it's still happening. Bug 88844
has not gone into the branch. Since the fix is in 88844, marking invalid.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Updated

16 years ago
Blocks: 99194

Comment 19

16 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=88844 has an nsbranch+ marking.  ji
- you may want to add yourself to that bug to track it's fix. Thanks.
(Reporter)

Comment 20

16 years ago
Verified with 09/26 branch build.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.