Closed Bug 982448 Opened 6 years ago Closed 6 years ago

some fxmetro pref's still being left behind with values without --enable-metro in the mozconfig

Categories

(Firefox :: General, defect)

28 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 - wontfix
firefox29 + verified
firefox30 --- verified

People

(Reporter: kjozwiak, Assigned: rstrong)

References

Details

Attachments

(2 files)

This probably isn't a high priority issue, but I found two pref's that have been left behind from fxmetro that still have values assigned to them (there might be more than these two)

- Attached a screenshot to illustrate the issue

Steps to reproduce the issue:

1) Download the latest BETA (Firefox Setup 28.0b9.exe)
2) Go to C:\Program Files (x86)\Mozilla Firefox\defaults\pref\channel-prefs.js and change the following:
- pref("app.update.channel", "beta"); --> pref("app.update.channel", "releasetest"); currently holding the BETA RC
3) Once Step #2 is completed, update fxdesktop via the "About" and restart
4) Go into the about:config and you'll notice that those two pref's are still being listed (this build should have everything fxmetro removed)

Any pref's that are associated with fxmetro should probably be removed.
Attachment #8389564 - Flags: review?(netzen) → review+
Assignee: nobody → robert.strong.bugs
Group: mozilla-employee-confidential
Robert, is this something that needs to get cleaned up before we release?
Flags: needinfo?(robert.strong.bugs)
No
Flags: needinfo?(robert.strong.bugs)
Summary: some fxmetro pref's still being left behind with values → some fxmetro pref's still being left behind with values without --enable-metro in the mozconfig
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #3)
> No

Okay thanks, nominating for tracking since Release Management is aware.
Pushed to mozilla-inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/5e03967817fa
Flags: in-testsuite-
Target Milestone: --- → Firefox 30
So since this is *not* needed before release, we can leave it for 28 and get uplift to Aurora when ready.
https://hg.mozilla.org/mozilla-central/rev/5e03967817fa
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Lukas Blakk [:lsblakk] from comment #6)
> So since this is *not* needed before release, we can leave it for 28 and get
> uplift to Aurora when ready.

I assume that means this is wontfix for Firefox 28.
Went through the verification process using the following builds:

builds with metrofx already removed:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-31-03-02-01-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-31-00-40-01-mozilla-aurora/

builds with metrofx still installed and removing it via the update:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-24-03-02-03-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-25-00-40-02-mozilla-aurora/

- Downloaded Nightly and Aurora that already had metrofx removed and ensured that the preferences from comment #0 have been removed
- Downloaded Nightly and Aurora that still have metrofx and than updated to the latest version, ensured that the preferences from comment #0 have been removed

Waiting on the next BETA build that will have all the metrofx removal changes.
Duplicate of this bug: 990711
Release drivers, the extra prefs don't cause any issues but if you'd like this uplifted approve the patch and I'll uplift it.
It seems low risk to me. So, sure, please. Thanks for proposing it.
I went through this again and double checked to make sure that the two pref's are being removed:
- Nightly (preferences have been removed)
- Aurora (preferences have been removed)

The two preferences are not being removed from the BETA builds, but the fix is being uplifted as per comment #11 & comment #12. I'll retest using the BETA channel once the uplift lands.
Comment on attachment 8389564 [details] [diff] [review]
patch rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Disabling Metro
User impact if declined: a couple of extra default prefs seen in about:config
Testing completed (on m-c, etc.): on m-c and m-a
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #8389564 - Flags: approval-mozilla-beta?
Attachment #8389564 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Considering that these extra prefs cause no harm and that it would take work to figure out why the tests aren't passing (I've already performed a diff between aurora and beta without there being differences in the test or the common files for the tests) can we just skip this on beta?
Flags: needinfo?(sledru)
Oddly enough, they went away on their own with the next push.
Robert, from comment #18, it seems that it is now working. So, we should just resubmit them...
Flags: needinfo?(sledru)
Because the issue described in comment #16, this didn't make it into FF 29.0b5 but was eventually pushed as per comment # 18 & comment #19.

I'll retest this with the next BETA. I double checked and verified that the pref's are still present in the latest BETA build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b5/win32/en-US/
Went through verification using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b5/win32/en-US/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b6/win32/en-US/

* installed FX 29.0b6 and ensured that both preferences from comment #0 have been removed
* installed FX 29.0b5 and ensured that both preferences from comment #0 have been removed once FX is restarted after the update

Note: I used the "betatest" update channel, I'll quickly double check using the official beta update channel once FX 29.0b6 is up there.
Went through verification using the following Nightly build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b5/win32/en-US/

Once the above build was installed, I updated to FX 29.0b6 using the offical beta update channel and ensured that the two pref's have been removed. Launched FX using all the available shortcuts just to make sure that there wasn't any issues.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.