Closed Bug 982707 Opened 6 years ago Closed 6 years ago

Handler function DebuggerProgressListener.prototype.onStateChange threw an exception

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 30

People

(Reporter: janx, Assigned: janx)

References

Details

(Whiteboard: [needs-coverage])

Attachments

(1 file)

In Trunk, when trying to reproduce bug #977919, this error sometimes happens:

E/GeckoConsole(  626): [JavaScript Error: "Handler function DebuggerProgressListener.prototype.onStateChange threw an exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/event-emitter.js :: EventEmitter.prototype.logEvent :: line 144"  data: no]Line: 144, column: 0" {file: "resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js" line: 56}]

The faulty line seems to be /modules/devtools/event-emitter.js:144:

let logging = Services.prefs.getBoolPref("devtools.dump.emit");
Attachment #8389894 - Flags: review?(poirot.alex)
Attachment #8389894 - Flags: review?(poirot.alex) → review+
Comment on attachment 8389894 [details] [diff] [review]
Move the "devtools.dump.emit" pref from firefox.js to all.js. r=ochameau

Review of attachment 8389894 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, that's it.
Back luck between bugs 974056 and 976679...
Blocks: 974056, 976679
Keywords: checkin-needed
Status: NEW → ASSIGNED
QA Contact: janx
Assignee: nobody → janx
QA Contact: janx
https://hg.mozilla.org/integration/fx-team/rev/0c36365d4e41
Keywords: checkin-needed
Whiteboard: [needs-coverage] → [needs-coverage][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0c36365d4e41
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needs-coverage][fixed-in-fx-team] → [needs-coverage]
Target Milestone: --- → Firefox 30
QA Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.