Closed Bug 982770 Opened 7 years ago Closed 7 years ago

Sidebar border and header styling are broken on Windows 8

Categories

(Firefox :: Theme, defect)

All
Windows 8
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: madhava, Assigned: mikedeboer)

References

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(1 file)

Sidebar splitter/separator and header styling are broken:

Now:    http://cl.ly/image/131r3a2F3X0P
Before: http://cl.ly/image/1d3i1v2O0g0b
I suspect it is from bug 960517.
Blocks: 960517
OS: Mac OS X → Windows 8
Hardware: x86 → All
Summary: Sidebar border and header seem broken → Sidebar border and header styling are broken on Windows 8
Blocks: theme-win8
The splitter issue is also visible in the Library window.
Whiteboard: [Australis:P3]
(In reply to Madhava Enros [:madhava] from comment #0)
> Sidebar splitter/separator and header styling are broken:
> 
> Now:    http://cl.ly/image/131r3a2F3X0P
> Before: http://cl.ly/image/1d3i1v2O0g0b

Is the 'before' state correct for Windows 8, and/or do we have a design for how this should look somewhere?
Flags: needinfo?(shorlander)
Flags: needinfo?(madhava)
(In reply to :Gijs Kruitbosch from comment #4)
> (In reply to Madhava Enros [:madhava] from comment #0)
> > Sidebar splitter/separator and header styling are broken:
> > 
> > Now:    http://cl.ly/image/131r3a2F3X0P
> > Before: http://cl.ly/image/1d3i1v2O0g0b
> 
> Is the 'before' state correct for Windows 8, and/or do we have a design for
> how this should look somewhere?

We have not designed a new look for Windows 8 here. Probably shouldn't be blue but I think we should handle that separately and just use this bug to unbreak them.
Flags: needinfo?(shorlander)
Flags: needinfo?(madhava)
Assignee: nobody → mdeboer
Comment on attachment 8394888 [details] [diff] [review]
Patch v1: restore sidebar splitter and header styles

Review of attachment 8394888 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8394888 - Flags: review?(jaws) → review+
Keywords: checkin-needed
remote:   https://hg.mozilla.org/integration/fx-team/rev/57122a5c7406

(I'm assuming this needs uplift and setting flags appropriately, please correct if necessary)
Status: NEW → ASSIGNED
Keywords: checkin-needed
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/57122a5c7406
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31
Comment on attachment 8394888 [details] [diff] [review]
Patch v1: restore sidebar splitter and header styles

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis, bug 960517.
User impact if declined: the vertical splitters (which sidebars have) look big and clunky on Vista, Win 7 and Win 8. This restores the 'old' style.
Testing completed (on m-c, etc.): landed on m-c and stuck.
Risk to taking this patch (and alternatives if risky): minor.
String or IDL/UUID changes made by this patch: n/a
Attachment #8394888 - Flags: approval-mozilla-beta?
Attachment #8394888 - Flags: approval-mozilla-aurora?
Attachment #8394888 - Flags: approval-mozilla-beta?
Attachment #8394888 - Flags: approval-mozilla-beta+
Attachment #8394888 - Flags: approval-mozilla-aurora?
Attachment #8394888 - Flags: approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.3; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0		
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0		

Verified as fixed on:
- latest Nightly (build ID: 20140327030203)
- latest Aurora (build ID: 20140327004002)
- Firefox 29 beta 3 (build ID: 20140327113732)
You need to log in before you can comment on or make changes to this bug.