Last Comment Bug 983046 - Lightweight theme causes extra title bar button area to draw on maximization and full screen under Windows 8 (desktop mode)
: Lightweight theme causes extra title bar button area to draw on maximization ...
Status: RESOLVED DUPLICATE of bug 982812
[Australis:P4+][not-on-aurora]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86_64 Windows 8
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: australis-cust 940455
  Show dependency treegraph
 
Reported: 2014-03-13 00:50 PDT by desiradaniel2007
Modified: 2014-03-17 04:04 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (345.39 KB, image/png)
2014-03-13 08:20 PDT, desiradaniel2007
no flags Details

Description User image desiradaniel2007 2014-03-13 00:50:04 PDT
The issue is reproducible under Windows 8 while in desktop mode.

Even when stepping into Element.mozFullScreen() or hitting F11, one can notice two title bar button areas drawn.
Comment 1 User image :Gijs 2014-03-13 03:32:34 PDT
Could you please:

- give us details of the version of Firefox you're using
- provide the contents of about:support (mainly to see if there's any add-ons that might be influencing this, as well as the 'Graphics' section to see if this is related to how Firefox draws to the screen)
- tell us whether you can reproduce this on a clean profile (apart from the lightweight theme, obviously)
- attach a screenshot?

Thank you!
Comment 2 User image desiradaniel2007 2014-03-13 08:20:09 PDT
Created attachment 8390542 [details]
screenshot
Comment 3 User image desiradaniel2007 2014-03-13 08:23:33 PDT
Firefox Nightly 30 (2014-03-13)

Did not occur with a clean profile, but it needs more testing as I don't get this all the time. (It is OK on my old profile right now.) Will come back here if I get it on a clean profile.

Application Basics
------------------

Name: Firefox
Version: 30.0a1
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Edge
Version: 2.1
Enabled: true
ID: {fe272bd1-5f76-4ea4-8501-a05d35d823fc}

Name: Lightbeam
Version: 1.0.8
Enabled: true
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Shumway
Version: 0.8.303
Enabled: true
ID: shumway@research.mozilla.org

Name: Add-on Builder Helper
Version: 1.7
Enabled: false
ID: jid0-t3eeRQgGANLCH9c50lPqcTDuNng@jetpack

Name: Quick Image Zoom
Version: initial.rev38
Enabled: false
ID: jid0-RW8E9KFMTaLKkM4HqIWfidw29wo@jetpack

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20140308030203
browser.startup.homepage_override.buildID: 20140313030202
browser.startup.homepage_override.mstone: 30.0a1
dom.mozApps.used: true
extensions.lastAppVersion: 30.0a1
font.internaluseonly.changed: false
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1394695815
places.history.expiration.transient_current_max_pages: 53425
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1393763962

Graphics
--------

Adapter Description: Intel(R) Graphics Media Accelerator 3150 (Microsoft Corporation - WDDM 1.0)
Adapter Description (GPU #2): NVIDIA ION (Microsoft Corporation - WDDM v1.2)
Adapter Drivers: igdumd64 igdumd32
Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: Unknown
Adapter RAM (GPU #2): 512
Device ID: 0xa001
Device ID (GPU #2): 0x0a76
Direct2D Enabled: Blocked for your graphics driver version.
DirectWrite Enabled: false (6.2.9200.16433)
Driver Date: 3-23-2012
Driver Date (GPU #2): 6-21-2012
Driver Version: 8.15.10.2697
Driver Version (GPU #2): 9.18.13.286
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic
Vendor ID: 0x8086
Vendor ID (GPU #2): 0x10de
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) Graphics Media Accelerator 3150 (Microsoft Corporation - WDDM 1.0) Direct3D9Ex vs_0_0 ps_2_0)
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.4 Beta
Version in use: 4.10.4 Beta

NSS
Expected minimum version: 3.16 Basic ECC Beta
Version in use: 3.16 Basic ECC Beta

NSSSMIME
Expected minimum version: 3.16 Basic ECC Beta
Version in use: 3.16 Basic ECC Beta

NSSSSL
Expected minimum version: 3.16 Basic ECC Beta
Version in use: 3.16 Basic ECC Beta

NSSUTIL
Expected minimum version: 3.16 Beta
Version in use: 3.16 Beta
Comment 4 User image :Gijs 2014-03-17 04:04:09 PDT
I think Blair tested this and it was fixed by bug 982812, as it is on Win7 for me.

*** This bug has been marked as a duplicate of bug 982812 ***

Note You need to log in before you can comment on or make changes to this bug.