Closed Bug 983631 Opened 7 years ago Closed 7 years ago

[Messages] After deleting a message thread the notification persists forever

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.3 wontfix, b2g-v1.3T wontfix, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- wontfix
b2g-v1.3T --- wontfix
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: noemi, Assigned: steveck)

References

Details

(Keywords: regression)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
julienw
: review+
Details | Review
Description: Accessing to a new incoming message through messaging app instead of notification and deleting the corresponding message thread without accessing to it makes the notification persists forever.

STR:
1- receive an incoming message, the corresponding notification is shown
2- launch messaging app
3- without accessing to the specific message thread, tap more icon "..." and select "Delete Messages" option
4- remove the message thread

ACTUAL:
The notification remains in the utility tray forever, there is no way to remove it, when tapping on it the following message appears: "This message has already been deleted"

EXPECTED:
The notification is properly removed

Environmental variables:
master build (03/13)
Device: hamachi
BuildId: 20140313064116
Gecko: 7312341
Gaia: b5d0f9b
Platform version: 30.0a1
Probably a regression of bug 855165

(In reply to Noemí Freire (:noemi) from comment #0)
> 
> ACTUAL:
> The notification remains in the utility tray forever, there is no way to
> remove it, when tapping on it the following message appears: "This message
> has already been deleted"

It should still be possible to remove it by swiping on it.
Blocks: 855165
blocking-b2g: --- → 1.4?
Keywords: regression
blocking-b2g: 1.4? → 1.4+
Assignee: nobody → schung
Attached file Link to github
Hi Julien, although the notification could be swiped out for sure, I still create a patch for that ;)
Attachment #8396973 - Flags: review?(felash)
Comment on attachment 8396973 [details] [review]
Link to github

We should try to factorize this code a little more.
Attachment #8396973 - Flags: review?(felash)
Status: NEW → ASSIGNED
Target Milestone: --- → 1.4 S5 (11apr)
Comment on attachment 8396973 [details] [review]
Link to github

Hi Julien, I moved the notification get and close part into the utils for avoiding the duplicated code. Thanks for the suggestion.
Attachment #8396973 - Flags: review?(felash)
Comment on attachment 8396973 [details] [review]
Link to github

Some comments on github but this is mostly good

Thanks !
Attachment #8396973 - Flags: review?(felash)
Comment on attachment 8396973 [details] [review]
Link to github

Patch updated per suggestion and add some changes to the test(looks a little bit wired... :/), thanks!
Attachment #8396973 - Flags: review?(felash)
Comment on attachment 8396973 [details] [review]
Link to github

r=me if you use my additional commit https://github.com/julienw/gaia/commit/608b401de93bd4450db4f32d033123fc9af3fb62 (please review these changes yourself! ;) )

If you want to change anything non-trivial, please request an additional review :)

Thanks for the good work!
Attachment #8396973 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #7)
> Comment on attachment 8396973 [details] [review]
> Link to github
> 
> r=me if you use my additional commit
> https://github.com/julienw/gaia/commit/
> 608b401de93bd4450db4f32d033123fc9af3fb62 (please review these changes
> yourself! ;) )
> 
> If you want to change anything non-trivial, please request an additional
> review :)
> 
> Thanks for the good work!

Thanks for the brilliant promise-based test case sample! I'll update it right aaway but just got few question about the test here:
https://github.com/mozilla-b2g/gaia/pull/17630#issuecomment-39705089
In master: 458e6f778c22fe2a5da589a420d9959da5e39123
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8396973 [details] [review]
Link to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 855165
[User impact] if declined: User need to clean the notification manually if the message is deleted.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: No
Attachment #8396973 - Flags: approval-gaia-v1.4?
You don't need approval to land on 1.4 if 1.4+ is set :) (see https://wiki.mozilla.org/Release_Management/B2G_Landing#v1.4.0 for more information)
Attachment #8396973 - Flags: approval-gaia-v1.4?
Hi,

Checked on today's (4/10) master build:
Device: Hamachi
BuildId: 20140410065312
Gecko: e177929
Gaia: 8697ff1
Platform version: 31.0a1

and it properly works. Thanks!
Tested and working 
1.5
Gecko 4bd8d51
Gaia 35ed2ac

1.4
Gecko e509c04
Gaia 3534b48
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.