Closed Bug 983655 Opened 6 years ago Closed 6 years ago

Star icon is not aligned in the overflowed panel

Categories

(Firefox :: Toolbars and Customization, defect, trivial)

30 Branch
defect
Not set
trivial

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: alice0775, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3-])

Attachments

(2 files)

Attached image screenshot
Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/f073b3d6db1f
Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140314030202

Str
1. Shrink browser window so that StarUI is in overflowed panel
2. Open overflowed panel

Actual Results:
Star Icon is slightly placed to the left in comparison with other icons
Severity: normal → trivial
Summary: Star icon is not alined if it is in overflowed panel → Star icon is not aligned in the overflowed panel
OS: Linux → All
Hardware: x86 → All
Whiteboard: [Australis:P3-]
Regression window(gx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/a7ec92db9f0b
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140122040406
Bad:
http://hg.mozilla.org/integration/fx-team/rev/767ee9d0f0c1
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140122043633
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=a7ec92db9f0b&tochange=767ee9d0f0c1

Regressed by:
767ee9d0f0c1	Mike de Boer — [Australis] Bug 916953: introduce separator in overflow panel buttons and bookmark star button gets different label when inside overflow panel. r=Gijs
Thanks Alice! That's a long time ago... I'll take it.
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
The change to the padding of the zoom-reset-button is a drive-by fix and can be moved to a separate bug.
Attachment #8392259 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8392259 [details] [diff] [review]
Patch v1: fix combined and menu-button buttons styling in the overflow panel

Review of attachment 8392259 [details] [diff] [review]:
-----------------------------------------------------------------

r+ assuming you've tested on Windows and Linux, as both of my build envs on those are a little messed up right now.

Also, is it just me or is the zoom button padding change fixing bug 984568? Please mark as a dep and close appropriately. Thanks!
Attachment #8392259 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed without the changes for the zoom-reset label, because that needs more work.

https://hg.mozilla.org/integration/fx-team/rev/ce510a8c2af9
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/ce510a8c2af9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Comment on attachment 8392259 [details] [diff] [review]
Patch v1: fix combined and menu-button buttons styling in the overflow panel

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: bookmarks button looks odd when in the overflow panel
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, CSS-only change.
String or IDL/UUID changes made by this patch: none
Attachment #8392259 - Flags: approval-mozilla-beta?
Attachment #8392259 - Flags: approval-mozilla-aurora?
Attachment #8392259 - Flags: approval-mozilla-beta?
Attachment #8392259 - Flags: approval-mozilla-beta+
Attachment #8392259 - Flags: approval-mozilla-aurora?
Attachment #8392259 - Flags: approval-mozilla-aurora+
Blocks: 983768
Reproduced in Nightly 2014-03-13.
Verified fixed 31.0a1 (2014-03-20), Ubuntu 13.04 x64.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 986442
Verified fixed FF 29b2, 30.0a2 (2014-03-25) on Ubuntu 12.04 x86.
You need to log in before you can comment on or make changes to this bug.