Closed Bug 983731 Opened 8 years ago Closed 8 years ago

Drop the lastgood requirement for nightlies off m-c

Categories

(Release Engineering :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jsmith, Assigned: RyanVM)

References

Details

Attachments

(1 file, 1 obsolete file)

In order to ensure we're running the latest m-c bits for daily smoketesting, an offline discussion has proposed that we switch to generating m-c nightly builds every three hours.
The e-mail thread made me think that it wasn't the frequency that was the issue, but the time. What if we moved the current periodic times by 3h? Eg, if we're building at 6pm now, build at 9pm instead.
Summary: Mozilla Central Nightly Builds for FxOS should be generated every three hours → Mozilla Central periodic Builds for FxOS should be generated every three hours
Attached patch change m-c to 1hr (obsolete) — Splinter Review
I think the frequency is an issue as well, because that directly affects the max interval between a push and "all clear" for nightly purposes. With a 6 hour interval, you're looking at up to ~10hr for that (6hr if you just missed the last periodic run + ~4hr for all builds to run). If we drop the interval to 1hr, that gets us to a ~5hr interval which is certainly better.

As discussed on IRC, I don't think per-push is needed since landings on m-c tend to be in spurts (i.e. sheriffs merging the 3 integration branches over a short period of time). But this will at least make sure that the last merge cset always gets a periodic run shortly after.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8391326 - Flags: review?(aki)
Summary: Mozilla Central periodic Builds for FxOS should be generated every three hours → Drop the lastgood requirement for nightlies off m-c
Per IRC discussion, lastgood doesn't really do what it claims on m-c, so let's just drop it. Also, set the periodic interval to 3hr to match the trunk integration branches.
Attachment #8391326 - Attachment is obsolete: true
Attachment #8391326 - Flags: review?(aki)
Attachment #8391337 - Flags: review?(aki)
Attachment #8391337 - Flags: review?(aki) → review+
Comment on attachment 8391337 [details] [diff] [review]
disable lastgood on m-c and change the periodic interval to 3hr

https://hg.mozilla.org/build/buildbot-configs/rev/4263564033b3
Attachment #8391337 - Flags: checked-in+
Duplicate of this bug: 983756
Blocks: 983756
No longer blocks: 983756
Blocks: 787449
In production
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.