Closed Bug 983770 Opened 7 years ago Closed 7 years ago

Australis: Unexpected scroll bar appears when zoom widget is in overflowed panel

Categories

(Firefox :: Toolbars and Customization, defect)

30 Branch
x86_64
All
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: alice0775, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(2 files)

Attached image screenshot
See Screenshot
reproduced on Ubuntu12.04
OS: Windows 7 → All
(See also bug 983768 for the percentage being uncentered)
Whiteboard: [Australis:P3]
I'm 90% sure this is a regression... :-(
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
I also noticed that the icons were 15x16 on my Windows machine when in customize mode, so I fixed that, too. The palette styling could be improved further, but that seems to not be entirely trivial (my immediate margin-bottom attempts didn't work) and outside of the scope of this bug, so...
Attachment #8394108 - Flags: review?(mdeboer)
Comment on attachment 8394108 [details] [diff] [review]
fix scrollbars in overflow panel when zoom or edit controls overflow,

Review of attachment 8394108 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +861,5 @@
>  
> +/* Make direct siblings overlap borders: */
> +.toolbaritem-combined-buttons + .toolbaritem-combined-buttons@inAnyPanel@ {
> +  margin-top: -1px;
> +  border-top-color: transparent !important;

Why did you need to add !important here?
(In reply to Mike de Boer [:mikedeboer] from comment #6)
> Comment on attachment 8394108 [details] [diff] [review]
> fix scrollbars in overflow panel when zoom or edit controls overflow,
> 
> Review of attachment 8394108 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
> @@ +861,5 @@
> >  
> > +/* Make direct siblings overlap borders: */
> > +.toolbaritem-combined-buttons + .toolbaritem-combined-buttons@inAnyPanel@ {
> > +  margin-top: -1px;
> > +  border-top-color: transparent !important;
> 
> Why did you need to add !important here?

Because I don't want to manually try to come up with selectors which override all the possible hover and active styles for the border, and have it break again at some point when the selectors for the hover/active cases change.
Comment on attachment 8394108 [details] [diff] [review]
fix scrollbars in overflow panel when zoom or edit controls overflow,

Review of attachment 8394108 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8394108 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/43b83424c05a
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/43b83424c05a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31
Comment on attachment 8394108 [details] [diff] [review]
fix scrollbars in overflow panel when zoom or edit controls overflow,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: combined toolbar buttons cause scrollbar in the overflow menu
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, CSS-only change
String or IDL/UUID changes made by this patch: none
Attachment #8394108 - Flags: approval-mozilla-beta?
Attachment #8394108 - Flags: approval-mozilla-aurora?
Attachment #8394108 - Flags: approval-mozilla-beta?
Attachment #8394108 - Flags: approval-mozilla-beta+
Attachment #8394108 - Flags: approval-mozilla-aurora?
Attachment #8394108 - Flags: approval-mozilla-aurora+
Verified this as fixed on Windows 7 64bit, Ubuntu 12.04 and Mac OS X 10.9 using:
- latest Aurora (build ID: 20140324150430)
- latest Nightly (build ID: 20140324030203)
- Firefox 29 beta 2 (build ID: 20140324101726).

The issue from the screenshot is no longer reproducing. Closing issue.
You need to log in before you can comment on or make changes to this bug.