Closed Bug 984148 Opened 6 years ago Closed 5 years ago

Folder syncing failing due to DataCloneError

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gerard-majax, Unassigned)

References

Details

On my Nexus S running Gecko and Gaia master, since a couple of days, some folders does not get synced correctly.

Logcat shows:
I/GeckoDump(  275): ERR: indexedDB error: DataCloneError from request as part of readonly transaction on object store "bodyBlocks"
I/GeckoDump(  275): ERR: onerror reporting: DataCloneError @ app://email.gaiamobile.org/js/ext/mailapi/main-frame-setup.js : 4749

Deleting the account and recreating mitigates the issue. But after some time, the issue is back.
I'm going to resolve this WFM since we haven't seen any indications of this in some time and we've fixed various email bugs where we were potentially creating unhealthy races between our calling window.close() and our IndexedDB transactions completing.  Additionally, we may have landed some fixes related to us making sure to flush downloaded Blobs.  Also also, there was an IndexedDB bug with SQLite journals getting rolled back that has been fixed on trunk that could explain this, perhaps.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.