Closed Bug 984301 Opened 6 years ago Closed 5 years ago

Google Chrome app is opened when tapping on the helper app in m.youtube.com

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Android
defect

Tracking

(firefox28 affected, firefox29 affected, firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected, firefox34 affected, fennec+)

RESOLVED FIXED
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox33 --- affected
firefox34 --- affected
fennec + ---

People

(Reporter: cos_flaviu, Assigned: karlcow)

References

(Blocks 1 open bug, )

Details

(Keywords: reproducible, Whiteboard: [country-all] [sitewait])

Environment: 
Device: Google Nexus 4 (Android 4.4.2);
Build: 28 RC;

Steps to reproduce:
1. Go to m.youtube.com;
2. Tap on a video from the list;
3. Tap on the helper app from the url bar.

Expected result:
Youtube app is launched.

Actual result:
Google Chrome app is launched.
tracking-fennec: --- → ?
Flags: needinfo?(esawin)
I can reproduce this on release, I think it's a site change.
I/ActivityManager(  704): START u0 {act=android.intent.action.VIEW dat=http://m.youtube.com/? flg=0x4000000 cmp=com.google.android.youtube/com.google.android.apps.youtube.app.WatchWhileActivity (has extras)} from pid 2973

I/ActivityManager(  704): START u0 {act=android.intent.action.VIEW dat=http://m.youtube.com/? pkg=com.android.chrome cmp=com.android.chrome/com.google.android.apps.chrome.Main} from pid 2973

YouTube does open, but Chrome opens forefront. Probably also related to the Chrome and YouTube application update on the 12th and 14th.
Flags: needinfo?(esawin) → needinfo?(wjohnston)
I see this happen with the Samsung stock browser on my phone too. AFAICT, we're firing the right intent though, Youtube just instantly decides to open their web page (and apparently doesn't respect your default browser choice at the same time). The log messages in comment 2 confuse me a bit...

Also, I only see it on the YouTube homepage, and not on actual video pages.
Flags: needinfo?(wjohnston)
Confirming that we are only launching the YouTube app (package com.google.android.youtube, activity com.google.android.apps.youtube.app.honeycomb.Shell$WatchActivity).

The YouTube app does not handle channel pages (home page including) on launch properly and seems to delegate that by firing a view intent for Google Chrome. If the YouTube app is never going to support channel page URLs on launch, we would need to consider this during app selection.
I pinged some YouTube contacts to see if they can/want to fix this.
tracking-fennec: ? → +
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 28 → unspecified
I can't reproduce this anymore, possibly fixed already?
I still can. Remember, this is only with the front-page on YouTube, not from within any particular video.
Mike can you reproduce using the front-page youtube page?
Flags: needinfo?(miket)
Yeah, I can reproduce from the front page now. Pretty sure I couldn't before, but it's consistent now (so I was probably doing something wrong).
Just Contacted Google about it.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [country-all] [sitewait]
filter on [mass-p5]
Priority: -- → P5
The bug is no longer reproducible.
Tested on Firefox release 34, Beta 35, latest Aurora 36 and latest Nightly 37.
Device: Asus Transformer Tab (Android 4.2.1).

Should I close the bug as worksforme?
Flags: needinfo?(kdubost)
Let's closed it as fixed, since Karl was in contact with Google about this.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.