[B2G] [RIL] [CDMA] call waiting isn't working properly. The 2nd remote party cannot hear voice.

RESOLVED FIXED in Firefox 30

Status

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: hsinyi, Assigned: hsinyi)

Tracking

unspecified
1.4 S4 (28mar)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:1.4+, firefox29 wontfix, firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

Attachments

(1 attachment)

cdma call waiting isn't working properly. 

STR:
1) A has a connection with B
2) C calls A, and A accepts it

Expected result:
C hears A

Actual result:
C doesn't hear A

This is a regression for Bug 881174. Sorry about that... ...
Just discussed a possible solution with Vicamo, I'll provide a patch tomorrow.
nominate as 1.4+ as it's a regression coming from 1.4+ bug 881174.
blocking-b2g: --- → 1.4?
It is a 1.4+ issue.
blocking-b2g: 1.4? → 1.4+
Posted patch v1Splinter Review
The problem results from the fact:
In bug 881174, we added a callback of holdCall that enforces call state change.
However, in call waiting scenario, only one call exists and the call state should remain connected as expected.

As in 3way calling scenario, holdCall() and resumeCall() isn't allowed. The callback functions are never called of course. So I'd suggest simply removing those callback functions because 1) they shouldn't be there for cdma call waiting scenario and 2) they are never called in 3way call scenario.
Attachment #8392730 - Flags: review?(vyang)
Attachment #8392730 - Flags: review?(vyang) → review+
Local tests pass. Let's wait for try result: https://tbpl.mozilla.org/?tree=Try&rev=5e95e2698f20
https://hg.mozilla.org/mozilla-central/rev/38a3545c5a6c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.