Closed Bug 984451 Opened 6 years ago Closed 6 years ago

Deploy APK Factory Stage (or setup developer push / daily push)

Categories

(Cloud Services :: Operations: Marketplace, task, P1)

x86
macOS
task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ozten, Assigned: jason)

References

Details

We've got a couple blocker fixes which need to go to APK Factory stage (https://apk-controller.stage.mozaws.net)

Manual push:
1) git pull master tip
2) Execute the following against the stage DB

    DELETE FROM apk_metadata WHERE manifest_url != 'https://mobile.twitter.com/cache/twitter.webapp';

or Setup Nightly push to stage

or give aking / kumar developer push access
Assignee: server-ops-amo → jthomas
Priority: -- → P1
Blocks: 984028
Blocks: 982843
Blocks: 982814
apk-factory-service updated to b52476d8e65ceffb7791b33ceee22c704aab2ca1. Do we need to also update apk-signer?
Signer does not need an update.

Thanks!
I think we are missing the graphicsmagick package in stage.

This provides a command line app `gm`

I'm seeing Android Icons, which is consistent with this missing.

Also emailed jason with a few more questions about stage setup.
GraphicsMagick is installed on stage. Are we seeing a traceback for this issue? How does gm node module know where to find `gm`?
gm is in a typical PATH

/usr/bin/gm on Ubuntu

> Are we seeing a traceback for this issue?

I'll look on Sentry, as you've helped me outside of this bug, just now. Thanks!
We are not setting $PATH so that is the probably the reason it is not working. Let me update our configs and re push to stage.
Cool, can we re-run the SQL after putting gm onto the PATH.

Thanks!
We pushed, but now I'm seeing corrupted .png files.

My dev environment is broken, I think the Hawk secrets in stage changed.

Digging.
Update: I think I see what the issue is.

I believe that the images get corrupted in the first response for an APK, but that cached APKs give the proper icons.

I think we should be good to start QA, as although this should be fixed ASAP, in practise the Marketplace will trigger the build and throw away the first APK.
Stage has been configured to update at noon daily. For dreadnot access please send me your password hash generated using the command in https://mana.mozilla.org/wiki/display/websites/Deploying to me via IRC.
Stage is looking good to me.

I'm either crazy, had some mistakes in my process or there was intermittent issues this morning.

Either way, once you guys sign off on stage, we should push to production.
Stage has been running an older RPM, so this invalidates testing.

Jason - can you re-run the SQL to clear out the metadata on stage.
Done. Kumar and Austin you both now have access to dreadnot dev and stage instances.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: AMO Operations → Operations: Marketplace
Product: mozilla.org → Mozilla Services
You need to log in before you can comment on or make changes to this bug.