Rename manifestdestiny -> manifestparser

RESOLVED FIXED in mozilla33

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Trunk
mozilla33
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The term "manifest destiny" (the name of our library for processing test manifests) is actually rather offensive to many native americans. It refers to a philosophy that was used to justify genocide in the 19th century:

http://en.wikipedia.org/wiki/Manifest_destiny#Native_Americans

I know that the term has had different uses throughout the last several hundred years, not all of them that offensive. I'm sure there was no malicious intent behind the original naming. Still, I can't help but feel that we should rename the package to "mozmanifest" to avoid potentially upsetting people. Even from a pragmatic perspective, the arguments around this stuff tend to be pretty unconstructive and I'd rather nip the possibility of one at the bud. 

Also, the import name for the library is "manifestparser", so it would make sense if the project name matched that.

This has been generally approved of by the other mozbase maintainers. There's not really that much to be done here:

1. Rename manifestdestiny -> manifestparser in setup.py
2. Update documentation
3. Create a new project on pypi called manifestparser

We can keep manifestdestiny around indefinitely for backwards compatibility. Projects can update the dependency at their own pace.
Decided it was time to actually do this. Did up a patch, here's a try run:

https://tbpl.mozilla.org/?tree=Try&rev=ecc01663b1db
Posted patch Patch (obsolete) — Splinter Review
Ok, this passes try so I guess it's good for review.
Assignee: nobody → wlachance
Attachment #8436073 - Flags: review?(ahalberstadt)
Comment on attachment 8436073 [details] [diff] [review]
Patch

Review of attachment 8436073 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, but the path is still testing/mozbase/manifestdestiny.. shouldn't that be changed too?
Attachment #8436073 - Flags: review?(ahalberstadt) → review-
(In reply to Andrew Halberstadt [:ahal] from comment #4)
> Comment on attachment 8436073 [details] [diff] [review]
> Patch
> 
> Review of attachment 8436073 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This looks good, but the path is still testing/mozbase/manifestdestiny..
> shouldn't that be changed too?

Where? As far as I can tell I moved the directory from manifestdestiny to manifestparser...
Comment on attachment 8436073 [details] [diff] [review]
Patch

Review of attachment 8436073 [details] [diff] [review]:
-----------------------------------------------------------------

Oh sorry, I think you're right. In the diff view it still says 'manifestdestiny' in the path names which confused me. But in the review view it looks like it was changed.
Attachment #8436073 - Flags: review- → review+
So for that upcoming release, and with an eye on PyPI, it will become a new product, right? Shouldn't we reset the version numbers then?
I think that would be confusing. I don't see any harm in continuing with the version we have.
This can go in now, I think. See try run: 
https://tbpl.mozilla.org/?tree=Try&rev=a0776fce4423
Keywords: checkin-needed
This is bitrotted. Please rebase.
Keywords: checkin-needed
Attachment #8436073 - Attachment is obsolete: true
Attachment #8437788 - Flags: review+
Updated, conflict was in a comment. Should work now.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1737dfde961b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Depends on: 1023883
Duplicate of this bug: 1024565
You need to log in before you can comment on or make changes to this bug.